FreePBX | Register | Issues | Wiki | Portal | Support

System error with default boot option

freepbx
Tags: #<Tag:0x00007fcd27206df8>

(Pa Si) #1

I have 2 options to boot at the yellow screen:

  1. SHMZ (2.6.32-642.6.2.el6.x86_64)
  2. PBX (2.6.32-431.el6.x86_64)

    The 1st option is the default option. However, if I leave the system to auto boot into this option, the system will give me the error ERST: Failed to get Error Log Address Range. Kernel panic - not syncing: VFS: Unable to mount root fs on unknown -block(0,0)

A- How can I fix this crash issue
B- If can’t fix it, how can I set the FreePBX to boot into the 2nd option by default?


#2

I am having the same issue. Repairing or fixing that installation would be good.


(Pa Si) #3

@duncanidaho How were you able to repair the installation?


#4

As of yet I have not been able to repair. I am waiting on an answer from the community


#5

The linux system that hangs is 3.10.0-693
I have to choose 3.10.0-514 to have a functioning operating system


#6

I can not seem to fix this bad OS install partition and I really want to remove or get it working. Its difficult to have to manually select an option. Any help would be appreciated. I don’t just want to delete each line from the edit window, as I am afraid it will break the overall system from booting or running at all. Hopefully someone can advise.


#7

Look at this link it will allow you to remove the kernel I believe. I have not attempted this as of yet in fear my system will not reboot.

https://www.centos.org/forums/viewtopic.php?t=2120


(Pa Si) #8

This is the place where your boot order is specified.

/etc/default/grub

For my 1st boot option (SHMZ) this file is located in

/boot/grub/grub.conf

This is the content of the file in my system.
# grub.conf generated by anaconda
_ #_
_ # Note that you do not have to rerun grub after making changes to this file_
_ # NOTICE: You have a /boot partition. This means that_
_ # all kernel and initrd paths are relative to /boot/, eg._
_ # root (hd0,0)_
_ # kernel /vmlinuz-version ro root=/dev/sdd2_
_ # initrd /initrd-[generic-]version.img_
_ #boot=/dev/sdd_
_ default=0_
_ timeout=5_
_ splashimage=(hd0,0)/grub/splash.xpm.gz_
_ #hiddenmenu_
_ title SHMZ (2.6.32-642.6.2.el6.x86_64)_
_ root (hd0,0)_
_ kernel /vmlinuz-2.6.32-642.6.2.el6.x86_64 ro root=UUID=cd67230b-16ee-44bf-9c41-057d3c496be2 rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=auto KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet_
_ title PBX (2.6.32-431.el6.x86_64)_
_ root (hd0,0)_
_ kernel /vmlinuz-2.6.32-431.el6.x86_64 ro root=UUID=cd67230b-16ee-44bf-9c41-057d3c496be2 rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=auto KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet_
_ initrd /initramfs-2.6.32-431.el6.x86_64.img_

Change the default value to the according kernel order might allow your system to boot into the 2nd option.


(Pa Si) #9

I have just tested modifying the grub.conf file to change the

default=0

to

default=1

and it default boot into the 2nd boot option (the PBX once).


(system) #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.