System drive insane?! + grandstream gpx2000

First I tried to add an grandstream gpx2000 Phone to the System.
[2017-11-15 08:25:09] NOTICE[30824] res_pjsip/pjsip_distributor.c: Request ‘REGISTER’ from ‘sip:***@192.168.1.***’ failed for ‘192.168.1.***:5160’ (callid: ***@192.168.1.***) - No matching endpoint found
[2017-11-15 08:25:09] NOTICE[30824] res_pjsip/pjsip_distributor.c: Request ‘REGISTER’ from ‘sip:***@192.168.1.***’ failed for ‘192.168.1.***:5160’ (callid: ***@192.168.1.***) - Failed to authenticate

And now my Softphone on my Laptop after I restart it dont work and say Sip error 408 but i dont change anything on the Softphone.
I run the current Version of FreePBX.

WTF none of my Phones work now!!!
I did just restart the Server nothing else.


Did you create your extensions as Chan_SIP or PJSIP?

The log you entries you provided indicate that the server replied with PJSIP but the errors suggests that your extensions were configured as Chan_SIP…

If this is what you did either recreate your extensions as PJSIP or change your SIP settings so that Chan_SIP listen to the port currently assigned to PJSIP…

Good luck and have a nice day!


The Intrusion Detection was driving inse.
But i cant still find the right settings on the GPX2000.
Chan_Sip like for the other Phones.

Maybe the PW to long?!

Hello @Username4488,

The password for the GXP2000 is case sensitive with maximum length of 25 characters.

Thank you,

Daniel Friedman
Trixton LTD.

The reason that’s important is because the system generated password in the GUI is 32 characters…

And the generated SIP secret length is user settable in Advanced Settings.

1 Like

so i generate a showerter PW bit dont work.
Maybe the Phone need some special to add.

1 Like

no idea the sshhttt still refuse to work.

You are trying to connect the phone through PJ-SIP, but you either haven’t set up the extension at all, or you’ve set it up in Chan-SIP.