System crash - 4 phones can call, but do not ring when called to


#21

I thought that as well at first and have tried it with zulu both on and disabled. It does show the same zulu verbiage for all calls though and the rest of them work.


#22

To clarify: I had disabled zulu at the extension level, not system wide. I am not able to disable it system wide as our crm link requires zulu to function properly.


#23

IMO, this thread has gone off track. I believe that you have strong evidence that the Polycom is unable to register as extension 119. Check the line key display on the phone – if not registered, an X is displayed over the icon.

If the phone is really not registered, it’s pointless to look at call logs – an incoming call is doomed to fail.

We should then determine what general area to look in; the problem may be with Asterisk, with EPM, or with the phone itself. That’s easy to determine. With the phone powered off, configure a softphone for ext.119 and see whether it can register and receive calls. If not, comparing the pjsip config files for ext. 119 and ext. 120 should provide more detail.

If the softphone works fine, shut it down, factory reset the Polycom and configure it manually for ext. 119. If it registers and can receive calls, the problem is almost certainly with EPM.

pjsip ‘Port to Listen On’ set to 5160 should not by itself be a problem. However:

What is going on here? Does the firewall have external port 5060 forwarded to internal port 5160? If so, that is not a valid configuration for Asterisk. This may have worked for the past three years because of a SIP ALG or a workaround in the config, but it is in general faulty, because Asterisk ‘knows’ it’s listening on 5160 and will use that port number in Contact headers.

Please describe the network configuration at both ends of the link, including make and model of any routers or firewalls.

BTW, when you post logs or other textual data, we prefer that you use pastebin.freepbx.org . If you choose to use pastebin.com, please be sure that Paste Expiration is set to Never, so that future readers of the thread can follow along.


#24

Both the softphone and the polycom have the same behavior. I have factory reset the polycom (many times) and it registers, can call out, incoming calls get sent to voicemail and the actual phone never rings. This is the same behavior a softphone will exhibit.

And just to clarify here, if I create extension 120 and use the SAME phone or the SAME softphone on the SAME network, it works flawlessly.

As for the network, the port settings were changed in the pjsip / chan_sip configs. I will need to look at it when I get back on my computer.

Thanks for the heads up on the pastebin, I didn’t know a fpbx version existed and will use in the future ;).


#25

Ok, sorted.

It was a corrupted database, i dropped the db and imported a backup of the db and now it works fine.