System Admin (Pro) stuck on update 10.13.66-1

Hi,

Currently receiving an error in the console whenever I execute a command from the CLI:

locale: /lib64/libc.so.6: version GLIBC_2.15' not found (required by locale) locale: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by locale)

Tried:

yum reinstall glibc-common

But this gives an error:

Installed package glibc-common-2.14.90-14.x86_64 not available.
Error: Nothing to do

I have the pro version of System Admin, and I tried to update the Distro to the latest version (10.13.66-12). Current version is 10.13.66-1, however the button is greyed out indicating “update in progress”.

Nothing appears to be actually happening however, and I suspect the update process is stuck.

Any ideas how to release the lock on the update script and try again?

I have tried fwconsole restart, mysqlcheck -A --auto-repair and system reboot - all to no avail

Try below:
yum install glib*
The above command will install all the packages and dependencies required for glib , glibc.

You may also like to update / upgrade system, if not done recently with below:
yum update
yum upgrade

usr/sbin/sysadmin_update_system --unlock

Many thanks Lorne. That fixed the System update. :slight_smile: I am now at version 10.13.66-12

However, unfortunately the glibc errors have not gone away, and I am now left with a NEW error:

/usr/bin/which: no java in (/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin)
readlink: missing operand
Try `readlink --help’ for more information.

I did try the readlink --help but am really no better off.

Thanks again.

Many thanks for this suggestion.

I tried both: yum install glib* and yum upgrade glib* . They both failed with the same error:

Loaded plugins: fastestmirror, kmod, refresh-packagekit
Setting up Install Process
Examining glibc-2.14.90-14.x86_64.rpm: glibc-2.14.90-14.x86_64
Marking glibc-2.14.90-14.x86_64.rpm as an update to glibc-2.12-1.47.el6_2.12.i686
Loading mirror speeds from cached hostfile
Marking glibc-2.14.90-14.x86_64.rpm as an update to glibc-2.12-1.47.el6_2.12.x86_64
Resolving Dependencies
–> Running transaction check
—> Package glibc.x86_64 0:2.12-1.47.el6_2.12 will be updated
—> Package glibc.x86_64 0:2.14.90-14 will be an update
–> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

     1. You have an upgrade for glibc which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of glibc of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude glibc.otherarch ... this should give you an error
        message showing the root cause of the problem.
     2. You have multiple architectures of glibc installed, but
        yum can only see an upgrade for one of those arcitectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.
     3. You have duplicate versions of glibc installed already.
        You can use "yum check" to get yum show these errors.
   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).
   Protected multilib versions: glibc-2.14.90-14.x86_64 != glibc-2.12-1.47.el6_2.12.i686

I then tried to: yum remove glibc-2.12-1.47.el6_2.12.i686

and got the following error.

** Found 7 pre-existing rpmdb problem(s), ‘yum check’ output follows:
glibc-2.12-1.47.el6_2.12.i686 has missing requires of glibc-common = (‘0’, '2.12 ', ‘1.47.el6_2.12’)
glibc-2.12-1.47.el6_2.12.x86_64 has missing requires of glibc-common = (‘0’, ‘2. 12’, ‘1.47.el6_2.12’)
glibc-common-2.14.90-14.x86_64 has missing requires of glibc = (‘0’, ‘2.14.90’, ‘14’)
glibc-common-2.14.90-14.x86_64 has missing requires of libc.so.6(GLIBC_2.14)(64b it)
glibc-common-2.14.90-14.x86_64 has missing requires of libc.so.6(GLIBC_2.15)(64b it)
libpri-1.4.12-6_centos6.x86_64 is a duplicate with libpri-1.4.11.5-1_centos6.x86 _64
libss7-1.0.2-7_centos6.x86_64 is a duplicate with libss7-1.0.2-2_centos6.x86_64
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx -2016-06-14-07-38BhNJQa.yumtx

My problem is I don’t know what version of glibc I should have or how to properly these errors.

Any further insights would be greatly appreciated.

Kind regards

Andy

You have a 32bit glibc installed. Remove it. (This is what the second thing is telling you to do)

yum remove glibc-2.12-1.47.el6_2.12.i686

Yes I tried to remove the 32 bit version but, as I mentioned above, I get the following error:

Transaction Summary
=========================================Remove 7 Package(s)

Installed size: 16 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
glibc = 2.14.90-14 is needed by (installed) glibc-common-2.14.90-14.x86_64
** Found 7 pre-existing rpmdb problem(s), ‘yum check’ output follows:
glibc-2.12-1.47.el6_2.12.i686 has missing requires of glibc-common = (‘0’, ‘2.12’, ‘1.47.el6_2.12’)
glibc-2.12-1.47.el6_2.12.x86_64 has missing requires of glibc-common = (‘0’, ‘2.12’, ‘1.47.el6_2.12’)
glibc-common-2.14.90-14.x86_64 has missing requires of glibc = (‘0’, ‘2.14.90’, ‘14’)
glibc-common-2.14.90-14.x86_64 has missing requires of libc.so.6(GLIBC_2.14)(64bit)
glibc-common-2.14.90-14.x86_64 has missing requires of libc.so.6(GLIBC_2.15)(64bit)
libpri-1.4.12-6_centos6.x86_64 is a duplicate with libpri-1.4.11.5-1_centos6.x86_64
libss7-1.0.2-7_centos6.x86_64 is a duplicate with libss7-1.0.2-2_centos6.x86_64
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2016-06-15-12-35S4JiHD.yumtx

Quick update…

This issue is now causing “reloads” to fail from within FreePBX.

exit: 255
locale: /lib64/libc.so.6: version GLIBC_2.15' not found (required by locale) locale: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by locale)
HANDLED-ERROR: FreePBX\modules\Endpointman->doDialplanHook() isn’t there, but the module is saying it wants to hook. This is a bug in FreePBX\modules\Endpointman
PHP Fatal error: Call to undefined function freepbx\modules\endpoint_apiapp() in /var/www/html/admin/modules/restapps/Restapps.class.php on line 935
Whoops\Exception\ErrorException: Call to undefined function freepbx\modules\endpoint_apiapp() in file /var/www/html/admin/modules/restapps/Restapps.class.php on line 935
Stack trace:

  1. () /var/www/html/admin/modules/restapps/Restapps.class.php:935

Okay latest development.

I forced an uninstall using rpm -e --nodeps --justdb glibc-2.12-1.166.el6_7.7.i686 --allmatches

Then tried:

yum install glib*

and got a whole load of dependency errors.

One of these errors suggests:

Error: Package: glibc-2.14.90-14.x86_64 (/glibc-2.14.90-14.x86_64)
Requires: glibc-common = 2.14.90-14
Installed: glibc-common-2.12-1.166.el6_7.7.x86_64 (@updates)

but trying “yum install glibc-2.14.90-14.x86_64” fails with:

"No package glibc-2.14.90-14.x86_64 available.
Error: Nothing to do

and

“yum install glibc-common = 2.14.90-14” fails with:

Loaded plugins: fastestmirror, kmod, refresh-packagekit
Setting up Install Process
Loading mirror speeds from cached hostfile
Package glibc-common-2.12-1.166.el6_7.7.x86_64 already installed and latest version
No package = available.
No package 2.14.90-14 available.
Nothing to do

I really don’t know what to do from here.

Here is the full output from yum install glib*…

Any help to resolve this would be very welcome as my system is broken without the correct glibc installation and my knowledge of Linux is really very basic.

Loaded plugins: fastestmirror, kmod, refresh-packagekit
Setting up Install Process
Examining glibc-2.14.90-14.x86_64.rpm: glibc-2.14.90-14.x86_64
Marking glibc-2.14.90-14.x86_64.rpm as an update to glibc-2.12-1.166.el6_7.7.x86_64
Loading mirror speeds from cached hostfile
Resolving Dependencies
–> Running transaction check
—> Package glibc.x86_64 0:2.12-1.166.el6_7.7 will be updated
–> Processing Dependency: glibc = 2.12-1.166.el6_7.7 for package: glibc-common-2.12-1.166.el6_7.7.x86_64
—> Package glibc.x86_64 0:2.14.90-14 will be an update
–> Processing Dependency: glibc-common = 2.14.90-14 for package: glibc-2.14.90-14.x86_64
–> Running transaction check
—> Package glibc.i686 0:2.12-1.166.el6_7.7 will be installed
—> Package glibc.x86_64 0:2.14.90-14 will be an update
–> Processing Dependency: glibc-common = 2.14.90-14 for package: glibc-2.14.90-14.x86_64
–> Finished Dependency Resolution

Error: Package: glibc-2.14.90-14.x86_64 (/glibc-2.14.90-14.x86_64)
Requires: glibc-common = 2.14.90-14
Installed: glibc-common-2.12-1.166.el6_7.7.x86_64 (@updates)
glibc-common = 2.12-1.166.el6_7.7
Available: glibc-common-2.12-1.149.el6.x86_64 (base)
glibc-common = 2.12-1.149.el6
Available: glibc-common-2.12-1.149.el6_6.4.x86_64 (updates)
glibc-common = 2.12-1.149.el6_6.4
Available: glibc-common-2.12-1.149.el6_6.5.x86_64 (updates)
glibc-common = 2.12-1.149.el6_6.5
Available: glibc-common-2.12-1.149.el6_6.7.x86_64 (updates)
glibc-common = 2.12-1.149.el6_6.7
Available: glibc-common-2.12-1.149.el6_6.9.x86_64 (updates)
glibc-common = 2.12-1.149.el6_6.9
You could try using --skip-broken to work around the problem
** Found 42 pre-existing rpmdb problem(s), ‘yum check’ output follows:
glibc-devel-2.12-1.47.el6_2.12.x86_64 has missing requires of glibc = (‘0’, ‘2.12’, ‘1.47.el6_2.12’)
glibc-headers-2.12-1.47.el6_2.12.x86_64 has missing requires of glibc = (‘0’, ‘2.12’, ‘1.47.el6_2.12’)
incron-0.5.9-2.el6.rf.i686 has missing requires of libc.so.6
incron-0.5.9-2.el6.rf.i686 has missing requires of libc.so.6(GLIBC_2.0)
incron-0.5.9-2.el6.rf.i686 has missing requires of libc.so.6(GLIBC_2.1)
incron-0.5.9-2.el6.rf.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
incron-0.5.9-2.el6.rf.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
incron-0.5.9-2.el6.rf.i686 has missing requires of libc.so.6(GLIBC_2.4)
incron-0.5.9-2.el6.rf.i686 has missing requires of libc.so.6(GLIBC_2.8)
incron-0.5.9-2.el6.rf.i686 has missing requires of libm.so.6
libpri-1.4.11.5-1_centos6.x86_64 has missing requires of libc.so.6
libpri-1.4.11.5-1_centos6.x86_64 has missing requires of libc.so.6(GLIBC_2.0)
libpri-1.4.11.5-1_centos6.x86_64 has missing requires of libc.so.6(GLIBC_2.1.3)
libpri-1.4.11.5-1_centos6.x86_64 has missing requires of libc.so.6(GLIBC_2.3)
libpri-1.4.12-6_centos6.x86_64 is a duplicate with libpri-1.4.11.5-1_centos6.x86_64
libss7-1.0.2-2_centos6.x86_64 has missing requires of libc.so.6
libss7-1.0.2-2_centos6.x86_64 has missing requires of libc.so.6(GLIBC_2.0)
libss7-1.0.2-2_centos6.x86_64 has missing requires of libc.so.6(GLIBC_2.1.3)
libss7-1.0.2-7_centos6.x86_64 is a duplicate with libss7-1.0.2-2_centos6.x86_64
libstdc+±4.4.6-3.el6.i686 has missing requires of ld-linux.so.2
libstdc+±4.4.6-3.el6.i686 has missing requires of ld-linux.so.2(GLIBC_2.3)
libstdc+±4.4.6-3.el6.i686 has missing requires of libc.so.6
libstdc+±4.4.6-3.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
libstdc+±4.4.6-3.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
libstdc+±4.4.6-3.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
libstdc+±4.4.6-3.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
libstdc+±4.4.6-3.el6.i686 has missing requires of libc.so.6(GLIBC_2.3)
libstdc+±4.4.6-3.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.2)
libstdc+±4.4.6-3.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
libstdc+±4.4.6-3.el6.i686 has missing requires of libm.so.6
libstdc+±4.4.6-3.el6.i686 has missing requires of libm.so.6(GLIBC_2.0)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libc.so.6
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.3)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.7)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libdl.so.2
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libdl.so.2(GLIBC_2.0)
nss-softokn-freebl-3.12.9-11.el6.i686 has missing requires of libdl.so.2(GLIBC_2.1)