System Admin Module - Notification - UPS Battery Backup

I love the new distro. My question is with the new System Admin Module and specifically the UPS Battery Backup notifications. What type of UPS is compatible?? Brand Make and Model would be great. Also should it be interfaced with USB or Serial???
Keep up the GREAT work!

The UPS portion of the System Admin Module should work with any APC or any APC compliant battery backup.

I’ve sucessfully connected a Powerware 5110 via USB to the PBX using NUT, but unable to get the email notifications in FreePBX to work for UPS events. Is there any further configuration required to have FreePBX send out these alerts via email?

It all uses the APC RPM and their config files. You can google to learn more about it.

Is this the APC powerchute rpm’s or apcupsd?

I tried apcupsd, it seems to work properly but email destinations in Sysadmin module have no effect.
If I configure manually the email address in the config file of apcupsd, there is no problem, I can receive notification.
So my question is : is apcupsd supposed to work with sysadmin ? Or maybe there is another package to work with ?

It uses the apcupsd RPM which you can yum install from the Distro Repos.

The email destinations are put in all the configs in the /etc/apcupsd/ directory

You will see a file for example called commfailure and inside that file it states

This shell script if placed in /etc/apcupsd

will be called by /etc/apcupsd/apccontrol when apcupsd

loses contact with the UPS (i.e. the serial connection is not responding).

You will see in that same file whatever email you set for the action of Communication Failure will be in that file.

This is all standard apcupsd settings that we just let you set from the GUI.

System admin
FreePBX Framework

Ok, but the GUI doesn’t update email address in any of config file.
I have to edit manually “SYSADMIN” to work.

OK well it just did for my test.

Does it update the other settings?

Yes it updates all others.
It doesn’t work just for UPS settings.
I tried reboot, amportal restart, retrieve_conf but no success.

So it updates which other options?

From Address : OK
Storage notification : OK
Intrusion Detection Notifications : OK

UPS Replace Battery : NO UPDATED
UPS Communications Failure : NO UPDATED
UPS Communications OK : NO UPDATED
UPS Off Battery : NO UPDATED

Oh now I see the problem

You are referring to the notification section. Looks like someone goofed on that. Those fields should only be displayed with sysadmin pro as their is a whole section to managing UPS’s in sysadmin pro. Sorry about that. I will get that fixed today.

ok nice!

System admin published.

I don’t know if it’s supposed to be solved, but same issue with this release.

Nope that is still being looked at and will be published and this thread updated when fixed.

Ok latest sysadmin now removes these entries from notification is sysadmin pro is not licensed. Sorry about the confusion.