System admin module disabled pending version 14

I’m not sure what happened but for some reason my module admin is showing me that the SYSTEM ADMIN module has been disabled because it depends on version 14… When I try to update it I get an error message that it is depending on PHP 5.6 or higher. When I checked the PHP install with YUM it appears it was not installed with YUM, however, yum is indicating that there are nearly 15 asterisk packages that could be upgraded and I’m reluctant at the moment.

What to do?

You did not tell us your system information.

This might be a bug.
Run first fwconsole ma upgradeall see if it updates it.

I tried the command fwconsole ma upgradeall and the response was

unable to install module versionupgrade:

  • FreePBX version or higher is required. you have

This in addition to the errors I mentioned above.

Then you’ll probably want to run fwconsole ma --edge upgrade framework

Would this need to be run through SSH console?

yes .

I tried a number of upgrades and they all failed. First of all there is a PHP version dependency between 13 and 14. So that was almost a non-starter. Second; when I was able to upgrade from 13 to 14 many configuration settings were set to factory defaults and so much data was lost. I was trying to keep my VPN keys static between versions… luckily for me I had a VMware snapshot between versions but that was a FAIL. As soon as I restored the previous version the system was unusable.

(a fresh install to 14 was a disaster; 14 has so many bugs in areas I depend on)

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.