System Admin Email Issues

Hi Everyone,

I recently setup a new FreePBX server on a CentOS 6 VM. I followed the steps from the wiki. Pretty much everything is working fine except for email notifications of voice mail messages. I’ve bought the System Admin module and have it running on the server, but emails are not sending. I’ve tried both Gmail and Office365 accounts and neither sends the emails. I was wondering if anyone knows what might be going on. I’m including a text file of the log from the debug. Any help would be greatly appreciated.

More details. I did an SSH into the system and got this:

[[email protected] ~]# postfix flush
postqueue: fatal: Cannot flush mail queue - mail system is down

I’m sure that’s what is causing the issue.

Google “postfix Cannot flush mail queue mail system down”

If one of the 81,900 answers there doesn’t solve the postfix problem, let us know.

1 Like

Been trying a few so far. Will report back if I figure a fix and/or what was causing the problem.

To try and restart postfix and then watch what happens:-

service postfix restart;tailf /var/log/maillog

This is what I get when I run the commans.

Now you have to see what is running on port 25 that is not letting postfix start

lsof -i :25

It’s sendmail. Should they both be running?

[[email protected] ~]# lsof -i :25
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
sendmail 1625 root 4u IPv4 10498 0t0 TCP localhost:smtp (LISTEN)

I stopped sendmail then restarted postfix and the issue seems to be resolved. Emails are now sending correctly. Thanks for the help!

They won’t both run on the same port, but now you can fix your startup with

man chkconfig

then

chkconfig blah blah