System Admin will be upgraded to Hangs

Ive been running along just fine and doing upgrades as needed or I see them. Anyway I tried to do a bunch of upgrades and now my voice mail is not accessible and just drops the call. Also we are not able to park calls any longer.
I have a sysadmin update that hangs up “System Admin will be upgraded to” Not sure where to even start. Im close to just reinstalling and reconfiguring everything as I have till tomorrow morning, and have been pulling my hair out over the weekend trying to fix it. Any Ideas, check this or anything would be great.


I found out that the problem i am having with vmail and parking etc was the g729 codec is failing. I now need to figure that out but still have the above problem.

Running (as root) ‘amportal a ma download sysadmin’ and then ‘amportal a ma install sysadmin’ should fix your problem!

Thanks much, When I ran that command I got the following:
Fetching FreePBX settings with gen_amp_conf.php…

Fetching FreePBX settings with gen_amp_conf.php…

PHP Fatal error: Uncaught exception ‘Exception’ with message ‘Cron line added didn’t remain in crontab on final check’ in /var/www/html/admin/libraries/BMO/Cron.class.php:99
Stack trace:
#0 /var/www/html/admin/libraries/BMO/Cron.class.php(189): Cron->addLine(’@daily [ -e /v…’)
#1 /var/www/html/admin/modules/sysadmin/install.php(91): Cron->add(Array)
#2 /var/www/html/admin/libraries/modulefunctions.class.php(2311): include_once(’/var/www/html/a…’)
#3 /var/www/html/admin/libraries/modulefunctions.class.php(2263): module_functions->_doinclude(’/var/www/html/a…’, ‘sysadmin’)
#4 /var/www/html/admin/libraries/modulefunctions.class.php(1821): module_functions->_runscripts(‘sysadmin’, ‘install’, Array)
#5 /var/lib/asterisk/bin/module_admin(68): module_functions->install(‘sysadmin’, false)
#6 /var/lib/asterisk/bin/module_admin(847): doInstall(‘sysadmin’, false)
#7 {main}
thrown in /var/www/html/admin/libraries/BMO/Cron.class.php on line 99

I need to make that error a bit more descriptive. There’s something wrong with your cron, and the problem SHOULD be in /tmp/cron.error

If you could paste the contents of that file, that’ll be awesome!

I’m getting this same error on multiple deployments. My /tmp/cron.error is empty.

Are you sure you’re getting the error “Cron line added didn’t remain in crontab on final check”?