System admin 12.0.22 upgrade error-failed to run installation scripts

Using module Administration and have an update from 12.0.18.1 to 12.0.22 for System Admin however it fails with the following message:


Sysadmin RPM needs to be updated! Run ‘yum update sysadmin’ as root to continue Error(s) installing sysadmin: Failed to run installation scripts.


I have of course tried to run the yum update sysadmin command from the command line but it returns:


[[email protected] ~]# yum update sysadmin
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Update Process
No Packages marked for Update


I do not use this commercial package so I’m not sure it really matters to my system. I see there’s a free activation but only to those who didn’t upgrade already so maybe the best thing is just to ignore this module?

What version is your distro?

I’m running FreePBX 12.0.51. Took me a while to find the command to tell me what Distro but it looks like the ‘cat /etc/schmooze/pbx-version’ command did it. If so, it would be 1.818.210.58-1

Same here.

PBX version:
[[email protected] ~]# cat /etc/schmooze/pbx-version
2.210.62-1

The system admin is now disabled. It’s important to fix this.

You are running such a outdated version of the Disto based on CentOS 5.X that was EOL 3 years ago now. You need to update to a modern Distro first.

Rats. I’ve tried to do that but somehow the system never works after the update. I spent three days on my last attempt but had to revert to an old unit when all the problems started showing up. I followed the steps in the wiki and other pages but no success.

I am having the same issue.
sysadmin module disabled, pending upgrade to 12.0.22. (*current version 12.0.17.2
message:
Installing sysadmin
Sysadmin RPM needs to be updated! Run ‘yum update sysadmin’ as root to continue Error(s) installing sysadmin:
Failed to run installation scripts

yum update sysadmin, I get:

Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Update Process
No Packages marked for Update

Now cant configure the base-file parameters in the endpoint manager (the issue that led to it).

cat /etc/schmooze/pbx-version => 5.211.65-21

Any Ideas? maybe a link to the next upgrade (12.0.19) from my current version to get it back moving?

thanks.

nevermind. i fixed it.

earlier this year I had issues updating. I had to hash out the schmooze-commercial links in the
/etc/yum.repos.d/FreePBX.repo.
unhashed it and now its working again.

Happy Easter.

Thanks Enzo, this was my exact issue as well. It would be nice if Sangoma support would elaborate on common fixes instead of try to harp on something that doesn’t pertain to everyone here having the SAME issue :slight_smile:

1 Like

I removed the hashes from the baseurl= lines but I still can’t get System Admin to get out of disabled mode. I still get the same errors as before except it does file files.
[[email protected] ~]# yum update sysadmin
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
addons | 1.9 kB 00:00
base | 1.1 kB 00:00
extras | 2.1 kB 00:00
pbx | 1.2 kB 00:00
updates | 1.2 kB 00:00
Setting up Update Process
No Packages marked for Update
[[email protected] ~]#
Running the Module Admin Check Online still tells me I need to run the yum update from the root.