Sysconfig issues

I installed Freepbx Distro SNG-7 on my server, upgrading to the latest version. It seems everything went smooth except for the IP config.

The first thing I noticed is that IP address was missing from the startup screen. The installation should have figured it out so that I could do the ensuring configuration. What should I do next? Before I start messing with the initial setup process, I returned home with this challenge to overcome. In the first picture, I added the IPADDR GATEWAY and NETMASK values myself. But in the last pic, there should have been IP address on the third column, which I later added to see if it works after reboot.
So, in all, my server is not accessible remotely.

hi again. Can you put it in layman’s terms?

If you want a static address

(And address netmask and gateway)

If you have a DHCP service on your network


You just commented it out.

I got it. Thank you.

I was able to connect with my server and admin page for about 5 minutes. After I configured firewall setting and moved on to configure SIP, then I was bumped out of the server. It said Connection reset by my ip port 22, and the yardful list of following error;
Connected to Asterisk 13.22.0 currently running on freepbx (pid = 16558)
[2016-01-22 09:04:48] ERROR[23726]: config_options.c:708 aco_process_config: Unable to load config file ‘acl.conf’
[2016-01-22 09:04:48] WARNING[23726]: named_acl.c:413 ast_named_acl_reload: Could not reload ACL config
[2016-01-22 09:04:48] NOTICE[23726]: cdr.c:4459 cdr_toggle_runtime_options: CDR simple logging enabled.
[2016-01-22 09:04:49] NOTICE[23726]: res_odbc.c:616 load_odbc_config: Registered ODBC class ‘asteriskcdrdb’ dsn->[MySQL-as
[2016-01-22 09:04:49] WARNING[23726]: pbx.c:6984 add_priority: Extension ‘s’ priority 13 in ‘macro-user-logon’, label ‘got
pass’ already in use at priority 9
[2016-01-22 09:04:49] ERROR[23726]: pbx.c:7208 ast_add_extension2_lockopt: You have to be kidding-- add exten ‘’ to contex
t clean? Figure out a name and call me back. Action ignored.
[2016-01-22 09:04:49] WARNING[23726]: pbx_config.c:1848 pbx_load_config: Unable to register extension at line 3963 of /etc

My server firewall at present has set the policy to src ip any (service port ssh). But there are numerous attacks from abroad. This has been the reason why connection was reset. I get to wonder what is different from the Freepbx firewall settings I just completed. I signed up VPN for better security. How do you guys set up in terms of firewall??

So as a part of Freepbx configuration, the default firewall uses Whitelist, which is enforced application-wise; in addition to this, I’ve got a firewall system set up for the physical server as well. I noticed there have been continuing attacks from Shanghi, so ruthless that my server shut down temporarily today while I was engaging in setting up the firewall. I wonder if VPN is enough. or does the Freepbx firewall protection help?

There is never a good reason for leaving ssh running on port 22, if you do, you will soon see why.

Firewall and security is going to be at my back-burner until I am satisfied. Please be magnanimous with; you can be more specific. Thanks anyway.

I’ve got another issue;
A network interface that is assigned to the ‘Trusted’ zone has been detected. This is a misconfiguration. To ensure your system is protected from attacks, please change the default zone of interface ‘eth0’.
What does this mean?

You would benefit from a thorough review of the wiki, starting with this page:


That’s probably my favorite error message ever. I don’t know what it means for your installation, but you might need to look at this at some point.

1 Like

I don’t know whether to laugh with you or not. When I first saw this, I thought Freepbx is joking and better humorous than my Bixby which I sometimes make it to joke or converse with me.

You are always down to the point. I just reviewed the guide and can’t wait to act on it when I get to work. Thank you.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.