Sysadmin update broke module on version 1.810.210.57-1 / 2.11.0.11

I am receiving this error when I attempt to upgrade sysadmin. I am currently on 1.810.210.57-1 / with freepbx version 2.11.0.11:

2.6.1 14_centos5 ERROR: Unable to install sysadmin. The sysadmin RPM you have installed is too old. Please update the sysadmin rpm via the command line, using yum install sysadmin
Error(s) installing sysadmin: •Failed to run installation scripts

I attempted to perform the yum update and received this response:

[[email protected] ~]# yum install sysadmin
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Install Process
Package sysadmin-2.6.1-14_centos5.noarch already installed and latest version
Nothing to do

  1. Is there a repo I should enable to get the latest version?
  2. Can someone supply me the old module to revert back?

You need to get on Centos 6. We dont build packages for Centos 5 anymore and have not for over a year.

Ok to help you guys out I am going to attempt to build a CentOS-5 RPM of sysadmin.

Can you do me a favor and give me the output of

cat /etc/yum.respos.d//etc/yum.repos.d/schmoozecom.repo

I am on CenOS 6.2 and I am receiving a similar message except with sysadmin-2.6.1-101 after upgrading. This is the error I receive when installing the sysadmin module:

2.6.1 101_centos6 ERROR: Unable to install sysadmin. The sysadmin RPM you have installed is too old. Please update the sysadmin rpm via the command line, using yum install sysadmin
Error(s) installing sysadmin: Failed to run installation scripts

I then tried the following:
[[email protected] ~]# yum update sysadmin
/usr/lib/yum-plugins/kmod.py:25: DeprecationWarning: the sets module is deprecated
from sets import Set, ImmutableSet
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Update Process
No Packages marked for Update

[[email protected] ~]# yum install sysadmin
/usr/lib/yum-plugins/kmod.py:25: DeprecationWarning: the sets module is deprecated
from sets import Set, ImmutableSet
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Install Process
Package sysadmin-2.6.1-101_centos6.noarch already installed and latest version
Nothing to do

Any help would be greatly appreciated - Thanks

I suggest you upgrade off of 2.210.62.X track. That track was only built for FreePBX 2.10. FreePBX 2.11 and all needed RPMs are in the 3.211.63 and 4.211.64 tracks.

Each track of the Distro is built for a specific FreePBX version. http://wiki.freepbx.org/display/FD/Updating+FreePBX+Official+Distro

CentOS 6.4
FreePBX 4.211.64-7

I have the same error that SysAdmin is disabled. When I run “yum update sysadmin”, it reports: “package sysadmin-2.6.1-155_centos6.noarch is already installed”

But the module is still disabled and reported as 2.11.0.7

Help?

I uninstalled the SysAdmin module, then tried to reinstall. After a long (3-4) minute delay, during which the Status box was empty, this appeared in the box:

"
Please wait while module actions are performed

2.6.1 130_centos6 2.6.1 155_centos6 Successfully copied LoadLicenseIfExists.php.
Listen 80"

It’s been sitting at this state for 10+ minutes now.

I am having the same problem on mine. Broken and I can’t fix it.
[[email protected] ~]# yum install sysadmin
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Install Process
Package sysadmin-2.6.1-18_centos5.noarch already installed and latest version
Nothing to do

I just installed FreePBXDistro-3.211.63-10 x86_64. After I got past some video driver problems (edit boot string and appended nomodeset) I found the system hanging at installing modules. I ssh’ed in to watch the system processes and found the log. It was spinning away on “sh: lsof: command not found” lsof wasn’t on the system. I did a which for lsof and a find under root for it and it wasn’t there. I did a yum install of lsof and the install happily completed.

Here is the RPM for CentOS 5. I have not tested it but it should work.

from your linux CLI do

rpm -Uvh http://yum.schmoozecom.net/schmooze-commercial/5/i386/RPMS/sysadmin/sysadmin-2.6.1-156_centos5.noarch.rpm

I just ran this on my 1.88.210.57 system. The rpm installs properly, but then goes into an infinite loop of saying

sh: lsof: command not found

When I hit ctrl-C, it gives the somewhat expected error:

error: %post(sysadmin-2.6.1-156_centos5.noarch) scriptlet failed, signal 2

For the record, lsof is of course present on the system and runs perfectly fine from the shell when I try it manually. For giggles, I tried linking /usr/sbin/lsof to /usr/bin/lsof, rpm -e’ing the package, and re-installing it. It installed without error.

I went back to Module admin and attempted to update to 2.11.0.21 and enable. After hitting confirm, the popup window where installation status messages are displayed shows absolutely nothing. The browser activity spinner spins for a second and then stops. Hitting X to close the popup at that point returns you back to the module admin page, which shows the module installed and enabled. System Admin is present on the Admin menu, and accessing appears to show all the correct pages.

So I would call that at least functionally fixed, for me, even if it was rather roundabout to get there. Thank you again for taking the time to make this available for those of us unfortunate enough to have upgraded to 2.11 on Cent5 platforms.

I’ve got the same thing. I’m setting up a NEW FreePBX box to replace my aging one, and have run the install with the LATEST distro, saw the alert that the sysadmin module was disabled, tried to update it, and it sits there for days (literally) with the last line being “2.6.1 155_centos6 Successfully copied LoadLicenseIfExists.php"
Listen 80”

What’s going on here?

OK, so Installed the LSOF, and it fixed the problem.
Thanks.

Hi, all. I started the ticket. Sorry for the late response.

I will test the rpm right now. Tony, I understand you have EOL’d my version, that makes perfect sense. But then the logic in FreePBX related to uploading modules is slightly flawed.

It disabled my current working version of sysadmin when the upgrade failed and wouldn’t let me roll back when it found the new upgrade was incompatible.

The problem is I cannot schedule production upgrades on-the-fly, based on software incompatibility issues I discover reactively. That could potentially cause downtime, if it were any other module. Is it possible you can resolve that logic in future module upgrades, when upgrading through the repository?

I’d rather not have an upgrade, or have the upgrade roll-back on failure, and let continue to use my current outdated version, than have the upgrade fail mid-process.

Thanks for all you guys do, and sorry for the long-winded reply. I’ll let you know how the rpm goes.

EB

[[email protected] ~]# rpm -Uvh http://yum.schmoozecom.net/schmooze-commercial/5/i386/RPMS/sysadmin/sysadmin-2.6.1-156_centos5.noarch.rpm
Retrieving http://yum.schmoozecom.net/schmooze-commercial/5/i386/RPMS/sysadmin/sysadmin-2.6.1-156_centos5.noarch.rpm
Preparing… ########################################### [100%]
1:sysadmin ########################################### [100%]
copying table from file '-‘
Shutting down Filesystem event daemon (incrond): [ OK ]
Starting Filesystem event daemon (incrond): [ OK ]
mv: cannot stat `/var/lib/asterisk/agi-bin/license-*.zl’: No such file or directory

Anything?

Interesting point…a question could also be:

Is there an automated/semi-automated/manual cross check procedure built to avoid pulling FreePBX Module’s updates (from the GUI/via CLI) IF all other basic requirements (e.g. unmet RPM dependencies/unmet RPM version requirements, unmet FreePBX track versions/unmet Linux requirements) are not automatically previously met?

Old (EoL) systems (thought as a whole of single complex components), sadly, should be left behind and this should happen (and it’s happening) for a lot of understandable reasons.

As happens for old Linux distributions which are not constantly updated and then upgraded to the next major version by administrators/users…nobody sane should pretend to (or should be invited to) run an old Linux distribution (or an appliance based on that) and have recent RPM versions provided through a constantly updated series of repositories too.

The rule is: if you are “crazy” enough to do it yourself…OK do it and compile the latest package version you need…no matter how old is your system, no matter what packages you have installed on it…if you’re lucky and brave enough…do it manually…but then forget any RPM or YUM methods…RPM and YUM maintenance is available for repositories necessary for current distributions only, for old ones they could be still found - frozen - for historic reasons only.

OR…if this is not the case (mean: we upgrade/update all, no matter what you’re running) a very strict separation between FreePBX Module’s updates (and their requirements) and underlying Linux distribution versions (each one with its RPM versions) is mandatory.

But I think this latest route is hard to pursue, better to invite users to upgrade at latest track locking out others that run old (EoL) systems (in terms of FreePBX/FreePBX Distro).

I think the FreePBX Distro was born to address some of the recently discussed issues.

Isn’t it?

Two reasons why I don’t upgrade are listed below:
-Every attempt to upgrade from script has failed to the tune of a broken staging/production system.
-Backup/restore fails between FreePBX versions, using the backup/restore module.

Something else to consider: telling people they essentially have to reinstall their system every year (this particular production system is 1 year old) is a little tough to justify. Isn’t there something smoother we can do to just block incompatible updates?

Luckily, in this instance, I’m only asking to roll-back to a previous system-admin module, so it works. I won’t upgrade without testing first, in the future.

Can someone provide the compatible version of the system-admin module?? That’s really all I need.

As previously posted, I’m having this issue at one client that is wholly current on FreePBX, Asterisk, and CentOS, so it’s not just a CentOS5 issue.

Tony, could you or someone else there please address this? It doesn’t seem reasonable to have to pay support to help fix an issue caused by what appears to be a bad module update.

Sorry for kinda highjacking this thread but it has already happened, so I will just add to it a bit :stuck_out_tongue:
I had my inhouse FreePBX running on 2.11 but on an old distro with CentOS 5. I had exactly the issue that the OP describes but I decided to that it was time to go for a fresh install on the latest distro. I used FreePBX-4.211.64-7-x86_64-Full-1379605000.iso and all went smooth. It installed with sysadmin 2.11.0.20 and seemed fine. Today however, I noticed that there was a newer version 23 released so I tried to install that. This however failed with 2.6.1 155_centos6 Successfully copied LoadLicenseIfExists.php"
Listen 80" error as leemaisel mentions. It just hangs there for more than 15 mins. So I found this post and trying the “yum install lsof” rebooted and tried to update sysadmin module again. This time it didnt appear to do anything but when I closed the dialogue box, everything now shows up-to-date and appears to function correctly.
So there appears to be some issue with LSOF and the latest version of sysadmin.

I’m quite sure nobody here in this thread used the word “reinstall” (and nobody suggested you to do that as a last chance).

There are proven scripts that were developed to help us to upgrade from a major version to another newest one (specifically for FreePBX Distro) and other developed to update within each major version…I though between 3.211.63 and 4.211.64, as example.

But this is OT for you now and I understand your points very well.

We should not forget that retro-compatibility is often a dream (especially when there are components like Databases in between…).