Sysadmin module upgrade fails to go to 100 percent

There has been many updates to the sysadmin module lately, just last night I received the notification for latest one:

UPDATE NOTICE: There is 1 module available for online upgrade sysadmin (current:

I have noticed a pattern- when I process the upgrade via the webgui is that the percentage does not get 100 percent; it is generally stops in 90’s. I generally give it enough time so that I am pretty sure it complete any tasks, then I close the little upgrade window. At that point, you cannot do some things like view an extension (will result in blank page). To fix, do a “submit changes” on a working module; I usually use a Follow Me extension, and then do the reload. Everything is good then and as far as I can tell the sysadmin module is upgraded and fine.

Note that I am on “4.211.64-7-” and that I have never had this issue with any other modules.

I am not sure if there any real issues other than the annoyance of having to hack around this problem.

I have almost same kind of issue
this is what i get after trying to install
2.6.1 123_centos6 ERROR: Unable to install sysadmin. The sysadmin RPM you have installed is too old. Please update the sysadmin rpm via the command line, using yum install sysadmin
Error(s) installing sysadmin:

Failed to run installation scripts

then i try with Command
then i get
yum install sysadmin
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile

any help would me highly appreciated

You will need to update your PBXiaF system. You are missing our updated RPMs

Any thoughts on my issue though? I am using the FreePBX Distro and I have the latest RPM’s, and in fact the module appears to upgrade successfully. To me it seems like a bug, but I wanted to see if anybody else has this issue.

Tried to upgrade via Module Admin ->, never completed upgrade. Locked up GUI tight. Rebooted system (sitting in my lab, not yet in production) and back to Module Admin shows System Admin Disabled;Pending Upgrade to Repeat upgrade locks up again. Relevant log entries shown below.

[2013-Oct-22 14:58:12] [INFO] (sysadmin/install.php:22) - Successfully copied LoadLicenseIfExists.php.
[2013-Oct-22 15:06:35] [CRITICAL] (admin/bootstrap.php:135) - Connection attmempt to AMI failed
[2013-Oct-22 15:08:04] [ERROR] (libraries/module.functions.php:1714) - [NOTIFICATION]-[freepbx]-[modules_disabled] - You have a disabled module
(repeats several times)

Please run:
yum update

Also your system isn’t “locked up tight”. The gui is waiting on a response from the AMI because you have mis-matched passwords in freepbx vs /etc/asterisk/manager.conf

YUM update isn’t something I routinely do on these systems. I figured Module Admin would catch the important stuff and have previously broken systems with updates in the lab. I thought “Check Online” was a limited equivalent of a YUM update.

Also curious about mismatched passwords. Currently the password in manager.conf is default, this is a fresh install of FreePBX distro (the first one I’ve tried after a few years of PiaF). No internal passwords should have been changed, only the admin login set at first boot. Am I missing something ? Where would I find the FreePBX “match” to the manager.conf password ?

I don’t understand what you are saying. Manager.conf is for FreePBX to connect to AMI. The distro creates a random password when it installed.

The FreePBX login is stored in the MySQL database.

As far as the yum update, you seem to have the Distro and FreePBX confused. Two different projects. Module Admin does not touch the system.

Sysadmin is a commercial module with OS dependencies. If you used the update scripts provided you would not have had this issue.

OK, I am confused, I freely admit it.
Per tm1000 "Also your system isn’t “locked up tight”. The gui is waiting on a response from the AMI because you have mis-matched passwords in freepbx vs /etc/asterisk/manager.conf"
I was trying to figure out where such mismatched passwords might be located, since this is a fresh install with defaults on everything but the basic login.

For the update I was simply using Module Admin to update everything before starting a configuration on the system. System Admin wanted to update, but the update hung up and never completed, and locked up the GUI. I rebooted the system from the console and tried the update again with the same result. Off to the boards. Per tm1000’s suggestion a YUM update fixed the issue, but I am trying to figure out why it occurred in the first place and if my procedures need to be modified. No changes were made by hand, everything through the GUI and the system is pretty raw. There should not be password and dependency issues. It seems to me that System Admin has a dependency that isn’t caught in the upgrade script. I don’t think there is/was a password mismatch, as everything works fine now.

Just trying to learn.

There is a dependency. Module Admin is for FreePBX modules, not the distro. You need to download and run the distro update scripts from the wiki to prevent this from occurring again.

The file that was mismatched was a db entry amppass ( I think) and it is contained under the correct user heading in /etc/asterisk/manager.conf

The amppass was not changed and remains at default in both locations. Not sure what the error was but cleared with the YUM update.

Thanks for clarifying the distro update process. I somehow skipped over that when doing the initial install. Have found it in the Wiki and both of my FreePBX Distro systems are now current.

This other issue is not really anything like my original issue. I just did an upgrade of sysadmin on another test box, and it ‘stopped’ at 95 percent. Again, I believe the upgrade is fine. After closing the little upgrading window, the sysadmin module shows the latest version.

Downloading sysadmin 157632 of 166233 (95%)

I am having the same issue on two systems. Whenever there is an upgrade for the sysadmin module then it seems to hang when updating the module. But it would seem that it is completing in the background. I wait a while and then close the upgrade window. Then it shows the Apply button and I click on that and everything seems fine.

Yes this is normal now as its has to reload apache which causes your session to die.

Just glad to see that I am not crazy :slight_smile: I am pretty sure there is nothing unique about my installs and was surprised nobody else was seeing the issue.

I was experiencing the sysadmin module stall as well. Good to know it’s just apache. Thanks!