Sysadmin module broke after module upgrade

i have try to uninstall and reinstall the module still no luck

This is a commercial module by Schoomze

may thank in advance

Please wait while module actions are performed

Successfully copied LoadLicenseIfExists.php.
checking for ftp_server field…already exists
checking for tftp_server field…already exists
checking for ups_enabled field…already exists
Checking for abnormalcallvolume…
FATAL ERROR

SELECT * FROM abnormalcallvolume [nativecode=1146 ** Table ‘asterisk.abnormalcallvolume’ doesn’t exist]SQL -
SELECT * FROM abnormalcallvolume

Trace Back

/var/www/html/admin/libraries/sql.functions.php:11 die_freepbx()
[0]: SELECT * FROM abnormalcallvolume [nativecode=1146 ** Table ‘asterisk.abnormalcallvolume’ doesn’t exist]SQL -
SELECT * FROM abnormalcallvolume

/var/www/html/admin/modules/sysadmin/install.php:296 sql()
[0]: SELECT * FROM abnormalcallvolume
[1]: getAssoc
[2]: DB_FETCHMODE_ASSOC

/var/www/html/admin/libraries/module.functions.php:1382 include_once()
[0]: /var/www/html/admin/modules/sysadmin/install.php

/var/www/html/admin/libraries/module.functions.php:1354 _modules_doinclude()
[0]: /var/www/html/admin/modules/sysadmin/install.php
[1]: sysadmin

/var/www/html/admin/libraries/module.functions.php:1036 _module_runscripts()
[0]: sysadmin
[1]: install

/var/www/html/admin/page.modules.php:241 module_install()
[0]: sysadmin

/var/www/html/admin/config.php:333 include()
[0]: /var/www/html/admin/page.modules.php

from an earlier posted

It has always been under the commercial repo as even though it is free it is still licensed as commercial.

In the kickstart of the distro install we do this.

sudo -u asterisk /var/lib/asterisk/bin/module_admin reload
sudo -u asterisk /var/lib/asterisk/bin/module_admin download sysadmin
sudo -u asterisk /var/lib/asterisk/bin/module_admin install sysadmin

Which tells it to download the module than install it since it is not part of the stock FreePBX and part of the commercial repos.

Tony Lewis
Schmooze Com, Inc.
FreePBX Developer

Paul

This was fixed within 5 minutes of rolling out the new module. Guess you caught it in that 5 min window. The newest version should be fine. We added a new feature to sysadmin called Abnormal Call Volume reports

I’ve had a similar problem … tried the “yum install sysadmin” and it didn’t work

Ended up uninstalling sysadmin through the GUI and then figured I could re-install, except now that won’t work either

[[email protected] ~]# sudo -u asterisk /var/lib/asterisk/bin/module_admin download sysadmin
Downloading 166266 of 166266 (100%)

Untaring…Done
Module sysadmin successfully downloaded
[[email protected] ~]# sudo -u asterisk /var/lib/asterisk/bin/module_admin install sysadmin
package sysadmin is not installed
Unable to determine sysadmin rpm version…exiting
The following error(s) occured:

  • Failed to run installation scripts

I’ve already installed lsof but still no joy … any other ideas?

That tells me you are not using FreePBX Distro and have not enabled the FreePBX Commercial yum repos on your non standard Distro install.

Hi Tony

This is using the FreePBX distro installed from the ISO and then upgraded over the last 6 months or so

I have core enabled … no idea about the commercial repos … they’re not listed in /etc/yum.repos.d as far as I can see … just one file

total 12
drwxr-xr-x. 2 root root 4096 Nov 2 16:31 .
drwxr-xr-x. 86 root root 4096 Oct 28 11:57 …
-rw-r–r-- 1 root root 1643 Dec 15 2012 FreePBX.repo
[[email protected] yum.repos.d]#

[[email protected] yum.repos.d]# cat FreePBX.repo

FreePBX-Base.repo

If the mirrorlist= does not work for you, as a fall back you can try the

remarked out baseurl= line instead.

[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.freepbxdistro.org/?release=6.3&arch=$basearch&repo=os
#baseurl=http://yum.freepbxdistro.org/centos/$releasever/os/arch=$basearch/
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

#released updates
[updates]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.freepbxdistro.org/?release=6.3&arch=$basearch&repo=updates
#baseurl=http://yum.freepbxdistro.org/centos/$releasever/updates/arch=$basearch/
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
mirrorlist=http://mirrorlist.freepbxdistro.org/?release=6.3&arch=$basearch&repo=extras
#baseurl=http://yum.freepbxdistro.org/centos/$releasever/extras/arch=$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
mirrorlist=http://mirrorlist.freepbxdistro.org/?release=6.3&arch=$basearch&repo=centosplus
#baseurl=http://yum.freepbxdistro.org/centos/$releasever/centosplus/arch=$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

#Core PBX Packages
[pbx]
name=pbx
mirrorlist=http://mirrorlist.freepbxdistro.org/?pbxver=3.211.63&release=6.3&arch=$basearch&repo=pbx
#baseurl=http://yum.freepbxdistro.org/pbx/3.211.63/arch=$basearch/
gpgcheck=0
enabled=1
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-FreePBX

[[email protected] yum.repos.d]# cat /etc/redhat-release
CentOS release 6.3 (Final)

Ok coupled with another posting on this subject in another forum I’ve managed to resolve the issue

first off I installed the commercial repo with wget, then I was able to do a yum clean all, yum install sysadmin

This then broke httpd’s configs (removing the listen 80 from httpd.conf and adding a schmooze.conf in conf.d with a bunch of new listen statements)

I then had to remove the schmooze.conf and re-enable the Listen 80 in httpd.conf (httpd refused to start until this was done)

so not ideal, but sorted

This is on a system built from the original ISO and then upgraded to beta and then from beta to release … but it was definitely a distro release first off (one of a dozen or more VMs we have running PBXs for different people)

the sysadmin module upgrade broke my system also.
Here is the output of trying to start httpd after it apparently fails:

[[email protected] html]# service httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: Warning: DocumentRoot [/var/www/html/aastra/] does not exist
Warning: DocumentRoot [/var/www/html/restapps/] does not exist
Warning: DocumentRoot [/var/www/html/restapi/] does not exist
httpd: Could not reliably determine the server's fully qualified domain name, using asterisk.dmbotanicalgarden.com for ServerName
[Sat Nov 02 19:40:38 2013] [warn] _default_ VirtualHost overlap on port 82, the first has precedence
[Sat Nov 02 19:40:38 2013] [warn] _default_ VirtualHost overlap on port 81, the first has precedence
(98)Address already in use: make_sock: could not bind to address [::]:82
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]

I’ll try the steps above to fix.

I have httpd.conf in /etc/httpd/conf
and schmoozecom.conf in /etc/http/conf.d
Please, where do I enable the listen in port 80?