Superfecta & version status

I have a fresh installation from the Distro for FreePBX
I read many forum posts about Superfecta 2.11.3 being “pushed” as legit upgrade with issues. I can’t find any installation guide for Superfecta. I uninstalled the version installed from the Distro (also the one it wants to now upgrade) and retro’d back to This version mostly works… I’m not sure I have it correctly installed although it does mostly indicate the incoming CID on the TV… Many of the CID sources do little or nothing to produce a CID for the OSD…

Question: without using external paid CID lookup sources, what are the best or optimum sources (available within the Superfecta module) to get a OSD indication of the incoming CID?

Question: Does the newest Superfecta 2.11.3 work with the latest 32 bit version of FreePBX?

Question: Do the experts still recommend de-installing the “Caller ID Lookup Sources” module and run with Superfecta as a stand alone module? I also read to un-install this module in an old forum post…

Thanks for any assistance known…



Where are you reading about: ‘being “pushed” as legit upgrade with issues’. There aren’t upgrade issues as far as I’m aware of. The biggest complaint people have about Superfecta 2.11 is that many modules are missing, this is normal though as we had to remove all of the modules that are against website’s TOS. However there are still quite a few.

I’ve got trunk provided, who called, open cnam.

Yes it works with 32bit FreePBX

Also we recommend uninstalling Caller ID Lookup Sources only because it’s not needed. And if you have them both installed and working they would only conflict in trying to determine who has the priority on setting CID.

As far as which module is the “best”, we would need to know your location. For CAN/USA, OpenCNAM is decent.

Any idea on where to find the installation guide, release notes or data sources supported for Superfecta 2.11.3? All my searches seem to end at a Jira webserver which I can seem to get beyond.

There is a wiki on the Dev site:

A list of mpodules in 2.11 is not maintained, but you can see the module filenames by browsing the code here:

What links could you not get past?

All my searches had ended up behind

I was googling “freepbx superfecta 2.11 release notes”.

I am not a developer and there doesn’t appear to be any links to request an account from the JIRA administrator. (My account here doesn’t work on the jira website.)

thanks for looking into this.

Thanks for providing the module list and dev wiki link. I was looking for Superfecta 2.11 to support the Send_to_email module. Can’t see it on the list. I tried the previous couple 2.11.? versions but it wasn’t there so I’m back to - not sure why that module would not be ported. I wouldn’t think it would have a TOS issue. Am I missing something? Is there a workaround to accomplish the same functionality (i.e. send to email)? How does one request a new feature/module for Superfecta?


That module was added to the 2.2 branch after it was forked to 2.11 so it sort of fell through the cracks. It is not a big job to migrate it, so I will make sure it goes out with the next update.

I look forward to the next update. :slight_smile: send_to_growl stopped working in with the latest Freepbx. Pear won’t install - requires PHP extension “mbstring” error. I haven’t tried with 2.11.3 yet since I miss send_to_email more than send_to_growl. I’ll look at them both when the next update comes out.

Your account DOES work there. Just like it DOES work for other users (whom are also not developers but have posted issues). This is why I am really confused. If you logged in here you are logged in there (automatically)

Send to email module is now available for Superfecta 2.11. Until the next update is pushed, you can manually install it by downloading the file:
and saving it to the folder:
and chown asterisk:asterisk

I just tried this on another computer and was able to automatically login to the developer Jira site. My primary computer refuses to let me pass. I will investigate further for configuration issues.

I appreciate your effort in making this available.

Try clearing cookies or logging out if you have to do so.