FreePBX | Register | Issues | Wiki | Portal | Support

Superfecta causes timeout during internet outage


#1

Customer had an internet outage today. Phones continued to work via PRI, but inbound calls took a very long time to (or failed) connect. I believe the issue was a delay in the timeouts on the superfecta. Turning off the superfecta fixed the problem.

Can anyone suggest an automated way to disable the superfecta if there is no internet connectivity?

Thanks.


(Dave Burgess) #2

I can’t, but it would be a cool feature to add.

Isn’t Superfecta maintained outside of FreePBX? If so, contacting them would be the logical next step, If Sangoma (or the community) is maintaining it, a Feature Request would probably be logical.

Some people have written scripts in the past that turn features on and off based on external stimuli. If you know how to disable and re-enable Superfecta from the command line (or even within Asterisk) without having to go a config reload, it could probably be handled simply enough through a simple watcher script.