Super quiet call when transferring to a ring group with an external number

After hours we have our phone system “patch” through the answering service. So they call 111-222-3333, the system sees it is after hours so it sends it to a ring group called after hours. That ring group has a number 444-555-6666# and it connects that call. The person can hear the answering service ok, but the answering service can barely here us. Is this a codec issue? or what? We are using super high end FXO card :slight_smile: (01:0b.0 Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface)

Any thoughts on where to start looking? Thanks for the help.


“normalize” the TX/RX settings on that dahdi channel

What do you mean normalize? I’ve run fxotune already.

A “normalized” audio stream will have both the received and transmitted channels at 0db on the 4-wire side of the 2-4 wire hybrid that the"super high end FXO card" is, apparently your FXO is not so balanced and you will need to correct for that, fxotune attempts to add the correct complex impedance to the termination of the 2-wire side to minimize reflections (which is not the same as echo, but often reduces it :wink: ), you should rerun that after any RX/TX gain changes.

I should mention, if I just call that number from the system it is crystal clear. In my setup(web gui) it apprears both gains are are 0. What file from the command line should I check just to make sure? Thanks.


change temporarily




if those forwarded calls are fine, then it is probably your service’s lines, what technology are you using for inbound calls ?

I did try that. It acts the same with a cell phone. Any other thoughts.

I am pretty sure until you get the RX/TX correct you will have a problem , if there are two dahdi channels involved then the problem is compounded, ears are quite forgiving but gains are logarithmic and accumulative.

To see what is going on, try while sitting next to extension 234, and wanting to test dahdi channel 3 and 1NXXNXXXXXX will be a local milliwatt test number you will discover that works :wink: I would hate to overload 15036971000 but some one here found that number that seems to work nationwide.

rasterisk -x 'originate local/[email protected] extension 234;rasterisk -x ' originate DAHDI/3/1NXXNXXXXXX application milliwatt';dahdi_monitor 3 -vv

Watch what happens, the lines need to be exactly the same length and 100% (about 14800 or a little more)

I’m getting an error when I try running that.

rasterisk -x ‘originate local/[email protected] extension 1009’;rasterisk -x ’ originate DAHDI/3/18009993355 application milliwatt’;dahdi_monitor 3 -vv

[[email protected] ~]# rasterisk -x ‘originate local/[email protected] extension 1009’;rasterisk -x ’ originate DAHDI/3/18009993355 application milliwatt’;dahdi_monitor 3 -vv
No such command ‘originate local/[email protected] extension 1009’ (type ‘core show help originate local/[email protected]’ for other possible commands)
No such command ’ originate DAHDI/3/18009993355 application milliwatt’ (type ‘core show help originate DAHDI/3/18009993355’ for other possible commands)

Visual Audio Levels.

Use chan_dahdi.conf file to adjust the gains if needed.

( # = Audio Level * = Max Audio Hit )
<----------------(RX)----------------> <----------------(TX)---------------->
Rx: 4 ( 4) Tx: 0 ( 0)

I’m sorry , if you don’t have “originate” available in asterisk for whatever reason you will have to bridge milliwatt() with a milliweatt number (not 18009993355) by some other means to use dahdi_monitor

I was able kind of test it by doing it a different way. If I call any number from inside the system it sounds great. But if I program an incoming route to a ring group, that dials the same number, the call sounds fine, then when it starts to dial the ring group I can here it get really soft. Does that make sense?

It makes the same sense to me as it always has, your RX/TX gains need adjusting.

How about you just change them randomly, rebooting after each change? I’m sure you will stumble upon better settings :wink:

Ok I will try that. I did change the RX to 5, and it was louder. But I was afraid to just change things randomly because of it causing an echo.

When they are balanced there will always be less echo, as I said way back when.

I understand but you mean balanced when you are watching dahdi_monitor or just even in the config(ie both 0)

I mean balanced as in what your ear ultimately hears in either direction, this is sometimes called a conversation :-), dahdi_monitor would show the same for RX and TX if the signal was the same, telecommunications services traditionally uses a “milliwatt test number” for a 0db signal and asterisk provides a milliwatt() application that does the same, I thought I explained all that before. . . .

You might have but I think some of it is going over my head. I get the change the rx/tx gain until it works method! :slight_smile: But won’t that effect for all other types of calls as well? And I’m not having any issue with those. Just when I’m on a call and the system dials another number with another line and bridges the calls.

Thanks for helping and sticking with me though.

You ignored my question “what technology are you using for inbound calls ?” I suggest you stop thinking and just try it :wink: , the theory is solid because that’s how analog telephony works.

Regular POTS lines into the crappy FXO card. I will break things, I mean test things tomorrow :slight_smile:

Then the answer should be obvious to you, one RX/TX out of balanced circuit, bridged to another out of balance bridge would compound the problem on a logarithmic scale I guess they don’t do math at school anymore :slight_smile: