Sudo: unable to execute ./install_amp: No such file or directory

I am having problems with installing FreePBX on ubuntu server 7.10

I have downloaded and unzipped it but running the command:

sudo ./install_amp

is creating the error from teh subject line.

Any ideas?

After you extracted the files you must enter the directory that was created. I’m assuming you did something along the lines of:

tar zxvf freepbx-2.3.0 (or whatever version you downloaded)

tar will create a folder named freepbx-2.3.0 so you then need to cd into that directory…ie:

cd freepbx-2.3.0 ./install_amp

That should start the install.

I am afraid i have already done that. Trying to run from the correct directory.
Does not work.

My folder is freepbx-2.3.1 by the way.
I run sudo ./install_amp. It asks me for the password.
Then it returns the error i put in the title.

is the install_amp file in that directory if you do an ls?

The other thing you may have to (but shouldn’t have to) do is chmod the install_amp file so it’s executable.

the file is there i can see it. Also i tried chmod ./install_amp but get :
chmod: missing operand after ‘install_amp’

I am afraid i am not sure how to use this command. :frowning:

I typed ls -l and get the following:

-rwxr-xr-x 1 505 … install_amp

Does that look right to you?

Well…you’ll also have to make sure that you have correct the php5 packages. What install documentation are you following? When I did my first install on Ubuntu Server 7.10 I found that I needed to follow bits and pieces from a couple of different documents. For the most part though, I followed this one:

Ubuntu 6.06 Install Documentation

It’s kind of hard to troubleshoot without knowing what you’ve already installed, etc. So any information you can provide will help.