Suddenly, call flow routing doesn't work thus no incoming call

My inbound route points to call flow control 0 (there is a second one configured)
This morning , suddenly, no incoming call are possible, with voice playing ss-noservice message.
To test, I have configured a third call flow control (2) identical to the first one and made inbound route to point to
This way, all is working correctly

These are the difference in call trace :

Failing one:

-- Executing [[email protected]om-trunk:18] Goto("SIP/Mediatrix1-00000006", "app-daynight,1") in new stack
-- Goto (from-trunk,app-daynight,1)
-- Executing [[email protected]:1] Set("SIP/Mediatrix1-00000006", "__FROM_DID=app-daynight") in new stack
-- Executing [[email protected]:2] NoOp("SIP/Mediatrix1-00000006", "Received an unknown call with DID set to app-daynight") in new stack
-- Executing [[email protected]:3] Goto("SIP/Mediatrix1-00000006", "s,a2") in new stack
-- Goto (from-trunk,s,2)
-- Executing [[email protected]:2] Answer("SIP/Mediatrix1-00000006", "") in new stack
   > 0x7f0fd80320e0 -- Probation passed - setting RTP source address to 192.168.0.39:5004
-- Executing [[email protected]:3] Log("SIP/Mediatrix1-00000006", "WARNING,Friendly Scanner from 192.168.0.39") in new stack

[2016-06-21 11:14:53] WARNING[3040][C-00000002]: Ext. s:3 @ from-trunk: Friendly Scanner from 192.168.0.39
– Executing [[email protected]:4] Wait(“SIP/Mediatrix1-00000006”, “2”) in new stack
– Executing [[email protected]:5] Playback(“SIP/Mediatrix1-00000006”, “ss-noservice”) in new stack
– <SIP/Mediatrix1-00000006> Playing ‘ss-noservice.slin’ (language ‘it’)
– Executing [[email protected]:6] SayAlpha(“SIP/Mediatrix1-00000006”, “app-daynight”) in new stack
– <SIP/Mediatrix1-00000006> Playing ‘letters/a.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/p.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/p.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/dash.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/d.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/a.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/y.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/n.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/i.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/g.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/h.slin’ (language ‘it’)
– <SIP/Mediatrix1-00000006> Playing ‘letters/t.slin’ (language ‘it’)

Then hang

Working one :

– Executing [[email protected]:18] Goto(“SIP/Mediatrix1-00000022”, “app-daynight,2,1”) in new stack
– Goto (app-daynight,2,1)
– Executing [[email protected]:1] GotoIf(“SIP/Mediatrix1-00000022”, “0?app-announcement-4,s,1:app-daynight,1,1”) in new stack
– Goto (app-daynight,1,1)
– Executing [[email protected]:1] GotoIf(“SIP/Mediatrix1-00000022”, “0?app-announcement-5,s,1:timeconditions,1,1”) in new stack
– Goto (timeconditions,1,1)

after timeconditions there is an IVR as destination

*** Note the first three rows in each situation :

– Executing [[email protected]:18] Goto(“SIP/Mediatrix1-00000006”, “app-daynight,1”) in new stack
– Goto (from-trunk,app-daynight,1)
– Executing [[email protected]:1] Set(“SIP/Mediatrix1-00000006”, “__FROM_DID=app-daynight”) in new stack


– Executing [[email protected]:18] Goto(“SIP/Mediatrix1-00000022”, “app-daynight,2,1”) in new stack
– Goto (app-daynight,2,1)
– Executing [[email protected]:1] GotoIf(“SIP/Mediatrix1-00000022”, “0?app-announcement-4,s,1:app-daynight,1,1”) in new stack

Shouldn’t the first “app-daynight,1” be “app-daynight,0,1” ???

Why these differences and why without touch anything ??

1 Like

I hate to simply say, “And me” but we have just found the same problem. We have two daynight settings. The 1st one dumps caller sin a blackhole while the 2nd one works fine.
Mike

FreePBX 13.0.137

Same issue here.
I had to downgrade the framework to version 13.0.131 to have it working again.

1 Like

13.0.137 me too

No problem for me to keep the new call flow in meanwhile…

A “curious” thing often happens, after a reboot, framework can’t connect to asterisk (or asterisk not running?)

I MUST issue fwconsole ma upgrade framework and reboot in order to have a working system.

Is this known ?

Yes it was known. It was a bug in framework that was fixed yesterday.

1 Like

BTW did you notice this message in your log? Did you run a scan locally? Usually friendly scanner is the user agent of sipvicious.

^ that was part of the bug. So it’s irrelevant.

Andrew, hope this is the correct place to comment this time as it looks like the same issue!

Also ran into this after applying yesterdays updates;

To resolve this same issue I had to change my Call Flow Control Index from the default in the GUI (0) to a
number other than 0 for it to begin working on the inbound routes again.

-Luke

Again. This has already been fixed in framework so it doesn’t require any changes.

BTW did you notice this message in your log? Did you run a scan locally? Usually friendly scanner is the user agent of sipvicious.

192.168.0.39 is the LAN Mediatrix ISDN gateway to which FreePBX is connected to, so I’m not worried about, should I ??

Ignore it like I said earlier.

Just upgraded , all is fine :+1: