Struggling with connection settings


I have a sip trunk that has no knowledge of FreePBX.

I have the following settings but have tried various methods to connect. The connection in peers does not show as available.

Where do I put the following details

Your SIP Trunk order has now been completed. Please see the required details below;

  • SIP Server Address:
  • Channel count: 2
  • Username: 4416xxxxxx
  • Auth ID: xxxxx.sipt
  • Password: +nnxxxxx
  • Company Domain: hosted.txxxxx

Your new User Phone Number(s) are as below;

  • 4416154xxxxx
  • 4416154xxxxx

The IP address range that the SIP server uses is -

Any help appreciated

That sounds like chan_sip; you should be using chan_pjsip, especially as chan_sip cannot handle:

cleanly, whereas this can be handled with the match/accept setting for chan_pjsip.

This sounds like a commercial limit, of a type that some people believed no longer exists. At such a low limit there seems no point in trying to implement it, as it is probably easier to let the calls fail.

server name

Having these different may be a problem, although maybe you only need Username for the client URI in the advanced settings. Some more clarification is needed from the provider.

As a general point, obfuscating the provider identity just makes it more difficult to help, and there is enough information that anyone using that provider would recognize them. It looks like it may be, which seems to be Cloud Direct’s Wholesale Hosted Communications, which appears to be owned by British Telecommunications.

However, if it is, Asterisk PBX SIP Trunk Configuration | VoiceHost doesn’t explain where auth-id comes from, and I suspect it has several unnecessary settings, and I think there type=identify section is incomplete.

Also, you should say what you have already tried, and provide logs of failed attempts.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.