Struggling with callcentric inbound

freepbx 2.5.2 and Asterisk here, new setup trying to add Callcentric DID and coming up short.

I’m not sure exactly where it’s failing, if it’s my end or callcentric’s.

Used this page:

To set up my trunk.

Outgoing Settings:
Trunk Name: callcentric

PEER Details:

Register String:
1777xxxxxxx:[email protected]/1777xxxxxxx

Also have some dial rules in there. Everything else is blank or default.

This works for outbound with an outbound route I have.

In /etc/asterisk/extensions_custom.conf I have:

exten => _.,1,Goto(from-trunk,${CUT(CUT(SIP_HEADER(To),@,1),:,2)},1)

Then in Inbound Routes

Description: Callcentric DID
DID Number: 1513xxxxxxx (my DID)
Signal Ringing: On (I’ve tried this both ways)
Destination: Doesn’t matter, right now it’s set to voicemail for extension 502.

What happens is, watching asterisk logs I make an incoming call to my DID. I see it trigger, I see the correct DID in the logs, I see it routing how I have it set, voicemail, ringing an extension whatever.

When I set it to ring an extension (a copy of X-Lite Beta) it rings. I answer. The dialing phone keeps on ringing.

When I set it to voicemail the logs show:

-- <SIP/callcentric-b67045b0> Playing 'vm-theperson.gsm' (language 'en')
-- <SIP/callcentric-b67045b0> Playing 'digits/5.gsm' (language 'en')
-- <SIP/callcentric-b67045b0> Playing 'digits/0.gsm' (language 'en')
-- <SIP/callcentric-b67045b0> Playing 'digits/2.gsm' (language 'en')
-- <SIP/callcentric-b67045b0> Playing 'vm-isonphone.gsm' (language 'en')

but the dialing phone keeps on ringing. Immediately after that bit of log I get:

== Spawn extension (macro-vm, s-BUSY, 3) exited non-zero on ‘SIP/callcentric-b67045b0’ in macro ‘vm’
== Spawn extension (ext-local, vmb502, 1) exited non-zero on ‘SIP/callcentric-b67045b0’

I’m stumped. No matter what I do the dialing phone never hears an answer, and just keeps ringing.

Where the heck do I even start?

I don’t suppose your Asterisk/Trixbox server is behind a NAT’d connection is it? From what you say it looks as though the calls are coming in correctly.

Callcentric has the best tech support of anybody I’ve worked with in this industry. You can’t call them but if you submit a support request they will go above and beyond to answer questions about Asterisk and FreePBX not really related to their service.

Here is the setup they helped me put together. If this doesn’t help login to your callcentric acct and submit a support request.

Trunk Name: Callcentric

Dial Rules: 1513+NXXXXXX

Peer Details:

User Details is left Blank

Register String: 17779998888:[email protected]


route name: from-cc

DID Number: 17779998888

Pick a destination

If all else fails add an inbound route called “from-pstn” with no DID number specified and pick your own destination

Here it is in 2012, and I have exactly this same problem. Did you ever figure it out? The only thing that works for me is the phone book. For everything else, the caller side just continues to ring while I see asterisk answering the call and even going to voicemail.

I added some of the peer settings that I was missing from your instructions, but that didn’t seem to change anything. The call makes it into my system, it’s just that the caller doesn’t seem to get connected to the destination unless it is the phonebook. For instance, if I set it to ring an extension and call it, my wife will hear it ring and pick it up but only gets silence. On my end, it just rings and rings forever.

I know there is not an RTP problem as I get audio back when I call into the phonebook as a destination. The sip connection seems to work fine also as it will ring the phones when I select my ring group as a destination. I also see asterisk answering the calls in the asterisk console.

Use these instructions, which I wrote:

Make sure you have session-timers=refuse

That seem to be the problem from the explanation of the behavior you mentioned (rings forever on caller side, call received but no audio on calle-side)