Struggling with basic installation - anyone willing to help?

Hi guys,

I’m just a newbie starting out on FreePBX but I think I’ve got the odds stacked against me because it shouldn’t be this hard just to install the system.

I’m using a VPS from OVH and they don’t seem to like me using the ISO Distribution to boot to. I tried to go the manual route but just got lots of errors. Not knowing the system, I don’t know if I’m going to need the “commercial modules” or not anyway so going this route might be a dead end.

I’m very familiar with IP and hosted PBX via our VPS’s but I’m not at all familiar with Linux so copying commands is really where I’m at.

Does anyone have the patience to walk me through this slowly? Should I just be finding an alternative VPS? I don’t want to do that as I have a whole bunch with OVH and I don’t really want to add another supplier and our price is based on our OVH cost also.

Appreciate any help I get. I know this installation stuff is boring for you when you know how to do it inside out.



Have you read these? I found them useful.

Why not just get VPS from and not mess with any of this and it just works out of the box.

And if you do not want to use Sangoma’s solution (hard to beat though) as listed above, Vultr is a solid host that lets you use your own ISO files.

I wrote a section on setting up a Vultr instance in my FreePBX 13 guide. The Vultr bits would be the same for 14. Well most of it is the same.

Hi all,

Sorry - I don’t seem to be getting alerts of people’s replies, which is why I’ve only just seen your responses.

comtech, I have looked at the guides and tried to work through them but I think that ultimately the issue is that OVH don’t allow the use of the distro ISO. There is no ability to boot from the ISO once I have downloaded it and I’m not smart enough with linux to know if I can work around those limitations.

I tried the manual install but I get a lot of errors that mean little to me and would mean that I need help through each agonising step. something I don’t want to put anyone through.

tonyclewis, thank you. I suppose the short answer is that freepbx = min $34.99/month, whereas OVH, where I have a lot of VPS’s are less than $5/month to start. Even if I need something slightly more powerful to run the Free PBX platform, it still won’t be anywhere near the price of freepbx. Also, I’m in the UK and I’d rather use something closer to home.

I was trying to keep the cost of moving from one phone platform to another cost neutral as I don’t want to have to jack our prices up. I don’t even know for sure yet if Free PBX compares. I see the reviews are good but I need to see it in action for myself. Screenshots I’ve seen are fairly crude and although that is not the measure of a system, it’s all I have to go on right now.

sorvani, I see that Vultr’s prices have a better entry level, though not sure which one I will need at this point for a basic Free PBX system. I still have the concern about geographical location which is more important I believe for VoIP that many other VPS uses. I am trying to find out where there servers are located and if they have any even in Europe let alone the UK.

Thanks for the guide. I will move onto that next.

Thanks again for all your replies.



Vultr hosting had a London server which is great for me. Already purchased a server and setup is under way. So much easier than OVH. Thank you.


Hola, si yo tambien tenia un VPS en OVH, me gustaba como funcionaba pero tuve el mismo problema que @simple , salvo que pude cargar e inciar la ISO pero no pude concretar la instalación.

Termine optando por la opción de un VPS en Vultr y la verdad que sí, es mucho más sencillo.
Tengo el FreePBX instalado y corriendo, ahora solo que abri un tema porque no puedo hacer llamadas “No puedo hacer llamados desde mi FreePBX instalado en VPS Vultr
Sí alguien puede aportar al tema me daría una gran ayuda


I tried a manual deployment of 13 13 on CentOS 6 today. Something’s wrong with the current Asterisk 13. It fails at the ‘make install’ stage. I just stopped in the see if anyone knows what’s up with that.

Where did you get “13 13” (sic) ?
How did it fail?