Strange problem with Asterisk SIP Settings

When I do a fresh install of FreePBX 4.211 I ran into 3 cases:

  1. Without configuring the external IPand local net, I can call into the PBX, and call out from PBX.

  2. Once I configure the IPs, I can only call out from PBX and no calls would come in.

  3. After configuring the external IP and local net, I have to set the IP Configuration to Public (it used to be Static IP) in order to dial out and dial in.

All 3 configurations, the trunk would register fine with the trunk. In configuration 2, when I tried to dial into the PBX using a cell phone, the Asterisk debug shows nothing. It looked like the call didn’t even reach the PBX.

Can somebody shine some light on this matter?


Do you have a load balancing router? If so, you’ll need to force all IP packets to one WAN if you want to use registration.

Are you sure that you are configuring your External IP correctly?

Does your router have SIP ALG? If so, turn it off.

The router does not have these advanced stuff. It is a simple router that my ISP gave me which only has a Telnet interface… not even GUI.

I used the auto configure button. I double checked the external IP and it matches with whatismyip on google…

Once again, there is no such option on the router for SIP ALG.

Oh one thing I want to add is I already have a physical PBX running with the identical setup. This PBX was setup by myself about 2-3 years ago and I didn’t use the FreePBX Distro. So now, it is about time to upgrade the entire software to the FreePBX Distro.

This PBX is currently receiving/dialing calls perfectly fine. It is the new PBX I am setting up (whether it is a physical machine or virtual machine), I have the problems listed in OP.