Strange Parking Lot Issue [Solved]

Hey there,
I noticed today that the BLF for my parking lots on my T38G were not lighting up so i thought i would try and call one.
Normally, this would result in a message saying “there is no call currently parked on this extension” or words to that effect.
Now all i get is hangup tones and a strange message in the Asterisk CLI.
Please see below.

– Executing [[email protected]:1] Macro(“SIP/1010-00000017”, “user-callerid,LIMIT”) in new stack
– Executing [[email protected]:1] Set(“SIP/1010-00000017”, “TOUCH_MONITOR=1370869557.25”) in new stack
– Executing [[email protected]:2] Set(“SIP/1010-00000017”, “AMPUSER=1010”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/1010-00000017”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“SIP/1010-00000017”, “1?Set(REALCALLERIDNUM=1010)”) in new stack
– Executing [[email protected]:5] Set(“SIP/1010-00000017”, “AMPUSER=1010”) in new stack
– Executing [[email protected]:6] Set(“SIP/1010-00000017”, “AMPUSERCIDNAME=My Name”) in new stack
– Executing [[email protected]:7] GotoIf(“SIP/1010-00000017”, “0?report”) in new stack
– Executing [[email protected]:8] Set(“SIP/1010-00000017”, “AMPUSERCID=1010”) in new stack
– Executing [[email protected]:9] Set(“SIP/1010-00000017”, “__DIAL_OPTIONS=Ttr”) in new stack
– Executing [[email protected]:10] Set(“SIP/1010-00000017”, “CALLERID(all)=“My Name” <1010>”) in new stack
– Executing [[email protected]:11] GotoIf(“SIP/1010-00000017”, “0?limit”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/1010-00000017”, “1?Set(GROUP(concurrency_limit)=1010)”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/1010-00000017”, “0?Set(CHANNEL(language)=)”) in new stack
– Executing [[email protected]:14] GosubIf(“SIP/1010-00000017”, “7?sub-ccss,s,1(from-internal,71)”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/1010-00000017”, “0?Return()”) in new stack
– Executing [[email protected]:2] Set(“SIP/1010-00000017”, “CCSS_SETUP=TRUE”) in new stack
– Executing [[email protected]:3] GosubIf(“SIP/1010-00000017”, “0?monitor_config,1(from-internal,71):monitor_default,1(from-internal,71)”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/1010-00000017”, “0?is_exten”) in new stack
– Executing [[email protected]:2] StackPop(“SIP/1010-00000017”, “”) in new stack
– Executing [[email protected]:3] Return(“SIP/1010-00000017”, “FALSE”) in new stack
– Executing [[email protected]:15] GotoIf(“SIP/1010-00000017”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,28)
– Executing [[email protected]:28] Set(“SIP/1010-00000017”, “CALLERID(number)=1010”) in new stack
– Executing [[email protected]:29] Set(“SIP/1010-00000017”, “CALLERID(name)=My Name”) in new stack
– Executing [[email protected]:30] Set(“SIP/1010-00000017”, “CDR(cnum)=1010”) in new stack
– Executing [[email protected]:31] Set(“SIP/1010-00000017”, “CDR(cnam)=My Name”) in new stack
– Executing [[email protected]:32] Set(“SIP/1010-00000017”, “CHANNEL(language)=en”) in new stack
– Executing [[email protected]:2] Set(“SIP/1010-00000017”, “ROUTEUSER=1010”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/1010-00000017”, “1?outbound-1-2-3-4-5-6-7-9-10,71,2:outbound-allroutes,71,2”) in new stack
– Goto (outbound-1-2-3-4-5-6-7-9-10,71,2)
[2013-06-10 21:05:57] WARNING[9930][C-00000019]: pbx.c:6390 __ast_pbx_run: Channel ‘SIP/1010-00000017’ sent to invalid extension but no invalid handler: context,exten,priority=outbound-1-2-3-4-5-6-7-9-10,71,2
== Extension Changed 101[ext-local] new state Idle for Notify User 1010
== Extension Changed 101[ext-local] new state Idle for Notify User 1012
== Extension Changed 101[ext-local] new state Idle for Notify User 1011

I have checked my Outbound Routes and there is nothing in there that starts with 7 so why is it even looking there?
All seemed to work fine yesterday but today not happy. I did install Asternic CDR Reports but have since disabled to no effect.
Thanks again in advance.
Mark.

Well that tells me something is not right on your system. I would try and uninstall the park module and reinstall it. I just did a new install and the configs for parking shows up just fine for me.

DId you restore a 2.10 system onto this 2.11 box. If so that could really cause issues as parking was 100% redone in 2.11. On a upgrade from 2.10 to 2.11 we migrate all the settings but on a backup and restore it would never migrate your settings.

Remove the Park Module. Then go into the database and make sure all park related tables are dropped. Then reinstall.

As per reply number 4, I already uninstalled and reinstalled and made no difference. I think I will just need to restore from older backup and see if I can trace where things went wrong.
Out of curiosity, is there any way to remove old servers from your listing in the portal?

Version?

Sorry. Didn’t think of version number for module… remembered to put in freepbx version for a change :slight_smile:
In module admin, all is up to date.
When i do a check for updates, there are only a couple of not installed things (CID Superfacta and text to speech).

Have noticed that in etc/extensions_additional.conf there is only pickup=*8
On another system, this is where all the parking lot details are. The same goes for features_general_additional.conf.
If i try to add in manually then on a reload they disappear and if i put into _custom for each it makes no difference.
I will try uninstalling module and reinstalling.
Any other suggestions?
Mark.

This has not made any difference.
I did have to disable FOP2 to be able to get the Apply Config button to work after removing module. But module removed okay and on reinstall still does not work.

Also updated FreePBX framework to 2.11.0.2. System I compared to is running 2.11.0.1 and waiting on the update to install.
Not sure if that is relevant.
Mark.

I know it is not a very helpful error, but if it can be solved will save me having to reinstall (and create another license for this box).
Mark.

So what exactly are you dialing? I am confused. A dial of 72 should never hit a outbound route. You sure you have parking setup with 72 as one of the slots?

Yes, Park is set up default as per distro installation.
Parking Lot extension = 70
Starting position = 71
Number of slots = 8

You can see from the CLI that i am dialing 72 yet it is trying to send it out through outbound routes.
As i said in features_general_additional.conf there is nothing in there relating to parking at all only pickup=*8.

[[email protected] ~]# cat /etc/asterisk/features_general_additional.conf
;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

pickupexten=*8
[[email protected] ~]#

Whereas in another system i have the below in that file

[[email protected] ~]# cat /etc/asterisk/features_general_additional.conf
;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

parkext=70
parkpos=71-78
context=parkedcalls
parkext_exclusive=no
parkingtime=120
comebacktoorigin=yes
parkedplay=both
courtesytone=beep
parkedcalltransfers=caller
parkedcallreparking=caller
parkedmusicclass=default
findslot=first
pickupexten=*8
[[email protected] ~]#

As for what i am doing, on any other system when i dial a parking lot number and there is no call parked on that extension, you get a message telling you that. I am simply dialling that extension to test that parking lots are working (in OP i said that this all started when i noticed BLFs for parking were not showing on phone one day).
Hope this explains a bit better.
Mark.

I just noticed i never gave the FreePBX version (thought i did in first post)
FreePBX Version 3.211.63-8
What i have done:
Fresh install of above version.
Restore from temp box with same version (built 2 days before)
Change password for freepbx user for CDR database
Install FOP2
Install Asternic CDR Reports
Update Framework to 2.11.0.2.
After this i noticed Parking was broken.

Problem was conflict with the Parking Pro module.
When i tried to make it change parking lots to 40 (41-49) it made no difference, but when i went to change back to 70 (71-79) it said it was already in use for Park +.
I uninstalled Parking Pro module and problem is now solved.
All parking info now shows up again in the features_general_additional.conf file as well.
Mark.