Strange loss of inbound audio even with routed public subnet non-nat, with linux routers

Hi guys. I wonder if anyone can shed any light.

Asterisk on x64 running about 12 simultaneous calls most of the time (25 - 30 extensions/users). I will be upgrading this box soon.

For a couple of years, we have been using a BeThere dsl connection, with a bridged public IP, bridged through a Thompson Speedtouch, which is fine except for the missing hardware firewall and qos/mangling etc. that I would like.

I arranged a BT broadband connection, and used a Mikrotik router with a Draytek 120 pppoe bridge modem. I then NAT’d to a private IP on the Asterisk/FPBX box. We started to lose the inbound audio a few minutes or up to ten minutes into a call, but just some of the time. I’m not sure how often, but it is a serious problem. Maybe 30 - 40% of calls, maybe more.

I thought it was a NAT issue, so I requested a routed subnet from BT, and then started to use this. This means the public IP is directly on the FPBX box (and Advanced SIP settings (nat) updated accordingly), but being routed through the Mikrotik. I even disabled connection tracking (NAT) as a whole on the Mikrotik.

The problem persisted.

I then tried the BT supplied Business Hub 3.0 router, in the routed mode (routed public subnet), and the problem was the same.
This router also runs linux though, the same as the Mikrotik.

So next, I reverted to my BeThere bridged connection, but using the Mikrotik & Draytek, and NAT’ing (I have to NAT if I want to use a router with this bridged connection, because it’s not a routed subnet, it’s just a bridged connection directly to the ISP… I get to use 4 IPs out of a subnet, and the gateway is on their network, rather than being my own router). Anyway, my firewall rules were good, I was dst-natting 5060 and 10000 - 20000, and rtpstart and rtpend were OK, I could also see the connections in the connection tracking… everything looks OK.
I tcpdumped the SIP packets and looked at them in wireshark and I don’t see anything untoward.

But, the problem remains.

So, I have now fully reverted to the original setup, which is the bridged BeThere connection, directly on the FPBX box, without a router on my end, or any kind of NAT (the ISP router acts as a bridge), and the problem seems to have gone.

So, it doesn’t look like it’s the ISP that’s the problem, but it seems that two Linux based routers (Mikrotik, and 2wire), are having this issue, even with NAT disabled, but the Thompson Speedtouch bridge is OK.

Any ideas?

I am expecting a Draytek any time now to try.


SIP ALG disabled and enabled makes no difference btw.