Strange Feature Code issue -

If you open a dial tone and dial *97 for voicemail, it says: The number you have dialed is not in service

But, if you dial *97 first, then initiate a dial tone, it works.

Might be something simple, but I’ve about pull all my hair out and no luck. Anyway to fix this to work both ways?

You don’t have the *97 code in the dial plan for the phone.

When you “cold dial” the dial plan is ignored.

Pulling hair out is usually not effective. Reading the documentation for the phones, specifically the section on dial plans or digit maps (different vendors call it different things) you would not have been so frustrated.

…the phone you’re using doesn’t have a dial pattern matching ‘##.’ and its default behavior causes it to strip off the leading '’.

In testing a handful of possible desksets for a client, I found one (Grandstream GXP 1400? Cisco SPA 504?) that essentially ‘ate’ the initial ‘*’: Take the phone ‘off-hook’; dial ‘*97’; the phone forwards ‘97’ to the PBX; and the call fails. (It’s hard to tell what’s going on, though, because the pseudo dial tone stops with the first key press, as it would on an analog system.) When you dial ‘*97’ before initiating the call – I assume you press the ‘dial’ button to do so – the phone forwards all three characters, and the call goes through.

I’m somewhat embarrassed to report the way I solved this issue was to add a couple of sentences to the test guide saying, ‘Don’t do that!’ (However, I also explained that, when and/or if they ever get around to selecting a preferred deskset, I’ll tailor a standard dialplan for the device that will play well with the PBX…)

The Grandstreams (at least the GXP1400 and 2100) include a config option to turn off “call features” which will stop them from eating the “*” like that.

If you (or anyone else) needs to know how to do that let me know and I’ll dig it out later tonight. Right now I have one foot out the door.

Eric /