Strange... extensions suddenly are no longer registered, but are net connected


#1

Hello,

I have and environment where phones connect & register to the PBX, (pjsip) and calls seem to work fine. Within 10 - 15minutes, the PBX doesn’t see the phone, and on an incoming call none of the extensions ring like if their not registered.
Not sure if this is related, but I noticed there is no NAT option on the extensions, not sure if that’s a derivative of pjsip, or something else, but PBX is in the cloud. Is there something I may be missing settings wise I need to change?

Log showing when we reboot a phone, then when we try to call in, the extension is not ringing.
Last note, if you pick up the phone of course it connects to the pbx and makes the call just fine.

= Endpoint 301 is now Unreachable
– Contact 301/sip:301@99.99.99.99:20083;x-ast-orig-host=192.168.33.169:20083 is now Unreachable. RTT: 0.000 msec
– Removed contact ‘sip:301@99.99.99.99:20083;x-ast-orig-host=192.168.33.169:20083’ from AOR ‘301’ due to request
== Contact 301/sip:301@99.99.99.99:20083;x-ast-orig-host=192.168.33.169:20083 has been deleted
– Added contact ‘sip:301@99.99.99.99:36341;x-ast-orig-host=192.168.33.169:36341’ to AOR ‘301’ with expiration of 3600 seconds
== Endpoint 301 is now Reachable
– Contact 301/sip:301@99.99.99.99:36341;x-ast-orig-host=192.168.33.169:36341 is now Reachable. RTT: 83.125 msec
– Removed contact ‘sip:301@99.99.99.99:36341;x-ast-orig-host=192.168.33.169:36341’ from AOR ‘301’ due to request
== Contact 301/sip:301@99.99.99.99:36341;x-ast-orig-host=192.168.33.169:36341 has been deleted
== Endpoint 301 is now Unreachable
– Added contact ‘sip:301@99.99.99.99:46125;x-ast-orig-host=192.168.33.169:46125’ to AOR ‘301’ with expiration of 3600 seconds
== Endpoint 301 is now Reachable
– Contact 301/sip:301@99.99.99.99:46125;x-ast-orig-host=192.168.33.169:46125 is now Reachable. RTT: 77.910 msec


(David55) #2

SIP registration is about how to route calls to a device with a dynamic address, not about how to authenticate calls from the device. If you match by user name, calls will go out perfectly fine even if the extension isn’t currently registered.

Why do you think you need a NAT option? These options are overused.


#3

I say NAT because it feels the inbound call gets to the router/firewall and it doesn’t know how to send the invite to the extension.
I also saw this but with no real resolve

Pjsip NAT issues - FreePBX / Endpoints - FreePBX Community Forums


(Chris Dolese) #4

assuming you’ve confirmed no issue with the PBX connectivity and if the following from the command line highlights consistent behavior … reachable then unreachable

grep -i reachable /var/log/asterisk/full

id consider looking into the firewall or the device handing off

would also be interesting to note however I think you hinted - do the phones indicate any such issue on the far side ? whatever the endpoints no reg indication - is it seen ? if not indicates further reason to look at the firewall and what’s handing off to it - more rare would be some policy on the switching


#5

It’s hard to described, but the phones register, lets call it 10 minutes and while the phone thinks it’s registered, the PBX doesn’t so when a call comes in, it goes straight to voicemail and devices are basically not registered according to pbx.

Can it be something on the client firewall/network, yes, but since there is no nat because of PJSIP, its just feeling a little strange like if it’s lost the path back to the device.
Going to test the time it takes and report back.


(Dave Burgess) #6

As always, phone “helpers” would be the first thing to check at the client end. If that isn’t the case, reset the Qualify timer to something a little more aggressive, like 1 minute instead of the 10 it defaults to.


(David55) #7

Please explain this. chan_pjsip supports asterisk inside NAT cases with media and signalling external addresses, and supports work rounds for endpoint inside NAT, but not aware it is (the cases that chan_sip nat= deals with) using comedia, force-rport, and rewrite-contact.


(Lorne Gaetz) #8

FreePBX does not have extension (asterisk endpoint) specific NAT GUI options for PJSIP as opposed to to what is seen in the GUI for chan_sip.


(Igor Dobrosavljevic) #9

It’s been a while since I posted that article so I don’t quite remember what my solution was but I am pretty sure it was actually firewall related. Pretty sure that following the firewall documentation to setup rules and NAT for SIP specifically solved this for us. Sorry I didn’t post to resolution when it was figured out but pretty sure it was several weeks after I first posted that at which point I completely forgot to update that.


(Igor Dobrosavljevic) #10

Also this was for phones connecting back to the PBX over the internet through the firewall’s WAN port. Not sure if you are having problems with local or remote extensions.


(Greg Snover) #11

I frequently have that problem here in Albuquerque with Comcast and some routers - solution is to change to TCP and the problem goes away!

There is no reason you should have to do this, but it is the go-to solution when we see the same problem.

Not all ISP’s are created equal…

Change one extension to TCP, and then change it on the phone (what kind are you using?) and see if the problem goes away. If it does, make the change permanent on all the extensions. You will need to tweak the Basefile to tell the phones to use TCP - EPM doesn’t do it automatically.


(system) closed #12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.