Strange droped calls and dtmf beeps


I’ve search for this problem on numerous forums but haven’t been able to find a helpful answer.

I have a system with

  • Asterisk 1.4.19
  • freepbx 2.4.0
  • 1GB RAM, more than enough CPU
  • Openvox A400P with 2 PSTN lines connected
  • 7 st2030 phones, in the same 100Mbps LAN.

I have a problem I can’t get rid of: Sometimes, when a call is received, after a while in the conversation, the sounds produced in the IP phone side are kind of encoded into DTMF beeps. The first time this happened to me, I thought someone was dialling on the same line, but I realized that the tones weren’t always the same and, they were produced when a sound in the IP phone side was produced.

Needless to say this makes the conversation impossible.

Please help! TIA,


This happens with any PSTN Analog VoIP device. Make sure you got the latest firmware. Report the problem to your hardware vendor. Sometimes people’s voices hit the right DTMF frequencies to trigger the DTMF tones. This is unavoidable with analog devices. With a digital line/device (T1 or ISDN), it is non-existant.

I didn’t mention any analog devices… there are a couple, but the problems occurs with the Thomson SpeedTouch 2030 phones.

The asterisk box has the openvox card, with 2 PSTN lines connected to it. The calls come from this source.



I’m not familiar with that model of phone, but I can make some general suggestions:

Look through the phone configuration to see if you can turn off any options that are similar to “in-band dtmf.”

Are you sure that it is the phone that is generating the DTMF and not the OpenVox card? Do you have the option of setting up a VoIP trunk and bypassing the openvox card to make some test calls?

I’ve checked the asterisk box, and the phones and they didn’t have “dtmfmode=inband”, the server had “RFC2833”. I’ve changed it to “info” so it doesn’t produce any sounds. I hope I got it right.

I noticed something that could be causing some echo problems. In the zapata.conf I have:

And in the phone I have another setting called: “Acoustic Echo Cancellation (AEC)” which is enabled. My question is, could this be causing the dtmf beeps, or more echo?

Thanks again for your help!