Stop receiving direct calls

I have freepbx 12.0.76.2 and pbx firmware 6.12.65-20. Every a few months I come into work and find 20+ missed calls. The calls are not coming through callcentric, they are coming directly to freepbx. Below are some examples from what I saw this morning.

2015-12-01 05:31:[email protected]@@222DEFAULTsincomingSIP/@@222@xxx.xxx.xxx.xxx-00001cb0

2015-12-01 05:31:[email protected]@DEFAULTsincomingSIP/[email protected]@xxx.xxx.xxx.xxx-00001cc3

How can I make it so callcentric is the only thing freepbx responds to and everything else is rejected? I already have allow anonymous set to no in the sip settings.

Hi!

If that is possible, put an ACL (Access Control List) on ports 5060 (and possibly 5061) UDP (and possibly TCP) on your firewall and only allow traffic from their servers to those ports.

You might also be able to do the same on the RTP ports (10000-20000 UDP) or you might have to allow traffic from everywhere on those ports…

(It depends on how they are setted up, sometimes the server you receive SIP information from is the the same one which sends audio.)

The other possibility is to upgrade to FreePBX 13, apparently its new firewall could also help you…

Good luck and have a nice day!

Nick

Thanks, I’ll give the acl a try.