Steps for downgrade Zulu from 3 to 2?


We are suffering oerformance issues since Zulu3 was upgraded. /usr/sbin/httpd command frecuently is overloading CPU next to 100%, and calls sound is choppy.

It seems there is any bug since we upgrade to Zulu 3 and I wonder if there is a method to downgrade back again to Zulu 2.

Any hekp please?


Unfortunately you can’t roll back the server component.

Restore a backup might be a option, but you will lose other changes as well.

I finaly downgraded the module on module admin, to a lower version before v3, and it started working properly again.

We are now having normal behaviour on CPU performance.

So, It must be a software error. Still seems to be buggy on 3 version.

Does anyone suffer same problems?


Why don’t you report this as an issue so we can look into it. Please open a commercial support issue. By rolling back you’ve now messed up your Zulu version if you ever upgrade again. You’ll have to reset the Zulu data otherwise you’ll have issues. For this reason we don’t advise rollback on Zulu but instead encourage opening support issues.

I say report this as a bug because you say it seems buggy and you have cpu issues but Zulu is very complex. A bug couldn’t be formulated on such sparce data. So if you could do us a favor and report this we could get to the bottom of it

Hi Andrew,

You did supose we have not reported the issue, and you are wrong. Getting commercial support sometimes it takes too long, and the problem we are suffering is critical enough to downgrade Zulu version. We make hundreds of calls in a few minutes, and calls quality is not good enough to talk to anyone because of this issue.

Anyway, two ours after we downgraded it, we received a message from sangoma advertising the origin of the issue was detected and reported to R&D team. Issue still persists so we couldn’t operate with this version on a production machine.

So… if we have to return back again to v3, you advirtise we have to reset the Zulu data. What do you mean? What do we have to do? I wil appreciate any information about this,

Best regards.

1 Like

I looked through the bug reports and can find no report of this.

Not in bug reports, it’s on commercial support.


Hi again!

Well, now it’s time to upgrade the PBX again to Zulu3. As I mentioned before, I had to downgrade the PBX because of an stability issue we suffered due to Zulu3 upgrade from Zulu2. We have about 120 extensions and 100 of them uses zulu, mostly for clic to call and chat.

So, I have cloned the PBX with a nwe deployment ID, tried to upgrade the allready downgraded zulu and I got the expected errors. This is what I got:

An exception occurred while executing ‘ALTER TABLE zulu_tokens ADD PRIMARY KEY (websocket_session)’:

SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‘’ for key ‘PRIMARY’

What can I do to solve this? I will appreciate any information.

Best regards.

You need to uninstall Zulu module so it removes all the DB tables. Then reinstall Zulu module.

Thank you tonyclewis.

Do I need to do any additional configuration after reinstalling it?


Yes you will need to make sure all your users or user groups have permissions for Zulu since those tables are being removed.

Fix on this page for this error:

Thanks for the information Lorne. I followed the steps to execute mysql setence, and it seemed that nothing happened because no rows where afected:

mysql> truncate zulu_tokens;
Query OK, 0 rows affected (0.00 sec)

Instead, I have updated zulu and no errors where found, so… is this enough or it is really necesary to uninstall Zulu and reinstall it again?

What do you think is best for this situation?

Thank you all!

Looks like you are good to go.

Update done!

I’ve tried Zulu2 either Zulu3, and it works, but I found and strange behaviour with the user passwords. I’ve been trying lots of times to log in zulu client and I got a reachment error. Even tried to lig in into UCP and it worked perfectly. Finally, I had to create a new user password, and now it works.

So, is there any consideration with user passwords? DO I have to create nuew ones for everyone?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.