Static CID name prefix when someone calls in from inbound routes -- II, the revenge


I posted this a while ago and received no feedback (

The problem for me is not getting CID name prefix to work with inbound routes by themselves: this can be done.

Problem is when you try to use inbound routes with ring groups, as the ring group re-writes the CID prefix.

In any case, this is what I would like to achieve:

  • Calls coming from ISDN line: display “ISDN: 1234567890” on the telephone
  • Calls coming from POTS line: display “POTS: 1234567890”
  • Calls coming from SIP trunk: display “VoIP: 1234567890”
  • Calls coming from another POTS line: display “Tell this guy to stop calling our old phone number: 1234567890” :))

Since I must use ring groups with timeconditions, I have no idea how to bypass the CID being re-written.

Any suggestions?

You can prefix existing CID with CID Name Prefix: in Ring Groups but Ring Groups does not rewrite or remove CID if this is not in use.

What version of FreePBX do you use? What distro do you use?

I am using PiAF. I upgraded just the other day, so now I’ll have to test again.

However, I do remember that, since the CID name prefix was intentionally blank in the ring group (the CID was prefixed in inbound routes, if I remember correctly), the ring group dialplan was branching (as the CID field was not blank, being set previously by the inbound route), then re-setting the field to “”. Again, if I remember correctly it had to do with the field being left blank.

I remember this striking me as very odd.

System was installed last November, was running Asterisk 1.6.0.something. Can’t remember FreePBX version. I’ll test again and report what I find.