./start_asterisk: line 43: /usr/sbin/safe_asterisk: No such file or directory

When I try and start asterisk I get…

Thanks in advance for anybody that can help.

-Tucker

[[email protected] freepbx-2.3.0]#
[[email protected] freepbx-2.3.0]# ./install_amp
Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking user…OK
Checking if Asterisk is running…FAILED
[FATAL] ./install_amp
Asterisk must be running. If this is a first time install, you should start
Asterisk by typing './start_asterisk start’
For upgrading, you should run ‘amportal start’
[[email protected] freepbx-2.3.0]# ./start_asterisk start

STARTING ASTERISK
./start_asterisk: line 43: /usr/sbin/safe_asterisk: No such file or directory
safe_asterisk: no process killed
mpg123: no process killed


Asterisk could not start!
Use ‘tail /full’ to find out why.

[[email protected] freepbx-2.3.0]#

I am using Cent OS 5 and the 1.4 files.

Either you don’t have asterisk installed which is a pre-requisite or you don’t have it installed in the default location. When you do a ‘make install’ of asterisk, it installs /usr/bin/safe_asterisk for you. The requirement is to have asterisk running before you run install_amp, however you choose to run it. However, you will run into other problems if you don’ have safe_asterisk so fix that and you should be fine.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

And safe_asterisk kept failing and restarting.

However, i blundered through a workaround (I was up all night with a sick child, so i’m a little hazy on the details).

I’ll be running through it again on for a Centos 5 writeup that i’m working on, but my workaround (from memory, caveat emptor) is as follows:

start asterisk from the command line - /usr/sbin/asterisk -vvvvg &

ok, now asterisk is running (as root, not a good situation for freepbx, but let the install_amp script get everything else correct)

./install_amp

kill asterisk

amportal chown

amportal start

I may be wrong about the order, but i just hammered through it.

I was installing over a Centos5 machine that I didn’t want to wipe with an ISO.

HPH. Will finish my writeup soon and get it posted.

i am having the same error…

i cannot get it resolved…

any further help would be nice!

how did you install Asterisk? Did you do a “make install” when installing it?

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

I had the same error when installing on Ubuntu 7.04, and was able to get around the error in the same fashion: by starting asterisk manually and running ./install_amp. The problem then came back on startup because the startup script insists on using safe_asterisk. I would have to agree with Philippe on this one, you probably had an issue during compile. I actually went back and re-compiled asterisk and zaptel and my issue disappeared.

i had same error on ubuntu 6.06 lamp server.according to http://www.freepbx.org/support/documentation/installation/install-process-for-ubuntu-6-06 it install with out error
in one step when downloading freepbx from sourceforg (svn co https://svn.sourceforge.net/svnroot/amportal/freepbx/branches/2.2 freepbx-2.2) some error ocrd.so i try with (svn co https://libavc1394.svn.sourceforge.net/svnroot/amportal/freepbx/branches/2.2 freepbx-2.2) its work fine but Checked out revision not same to the doc. i try lot of times this.pls some advise me which step i missup.

thnks
bandara