Standalone System Chrony Setup, Help Please

We just installed a SNG7 vsn 2002 ISO on a standalone server with Digium phones (the system will be used for off-grid emergency communications). When connected to the Internet the phones get the correct time from time servers. When the Internet access is removed and the system rebooted the FreePBX server and the Linux system show the correct time but the phones have a date of Feb 4 with an incorrect time.
I have spent hours playing with the /etc/chrony.conf file with no luck. The file currently contains:

server localhost iburst prefer
server iburst
server iburst
server iburst
driftfile /var/lib/chrony/drift
makestep 1000 1
local stratum 10
logdir /var/log/chrony

The standalone server address is obviously and is both the FreePBX server and the time server. The phones are currently directly connected to the server using a switch, so no network firewall is a problem. Any assistance is greatly appreciated…
Thanks, Ron

You need to set the time zone settings in the phone. Generally this is done via the GUI or provisioning server or they could get them via DHCP options from the DHCP server.

The timezone is set in the phone. It is not just the hour that is wrong, the date is also significantly off. Chronyc activity shows all 4 sources as unknown addresses even though they are plugged into the same switch. Again, any assistance greatly appreciated.

If the FreePBX server itself is able to keep the correct date/time, which it should, you could set it as the NTP server for the phones.

Surely someone on the forum has a suggestion on how to make the standalone time work correctly???
Thanks, Ron

This is a known upstream problem. Chrony discards sources when dns lookup
fails. If you need to put Chrony online before dns is available use IP

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.