SSL Certificates are not being updated in Browser


#1

I have successfully update the certificate in the certificate manager and it shows expiration in August 2020. However the web admin side still shows the old certificate which expired in 9. May 2020. In more detail the browser certificate is the old one when I browse the admin panel.

How can I fix this?

FreePBX 15.0.16.49


(Volkswagner) #2

I’m having this same issue.

FreePBX 14.0.13.34
problem still occurs after updating cert manager to 14.0.8.1

I tried creating a new self signed certificate and assigning it in HTTPS settings.
Even after applying the self signed cert, the HTTPS settings page still shows
cert as being from CA=LetsEncrypt

I’ve tried restarting HTTPD several times, also tried fwconsole reload.
I’ve tried assigning the default to my self signed cert, and also deleted and
created self signed cert. Always HTTPS setting shows LetsEncrypt cert as the
CA, which is not possible with self signed.

What else can I try?


(Volkswagner) #3

Well there is some sort of bug in Certificate Manager.

After rebooting, I was able to assign my self signed cert, then assign
the LetsEncrypt Cert.


(Jared Busch) #4

More likely your browser was caching things.