Sporadic FreePBX Setup


(Bob) #1

I have everything working at my desk finally but struggling to get Zoiper working on mobile using OpenVpn on PFsense. Anyone successfully able to get this to work? I can hear incoming calls but they can’t hear me and I can’t dial out with normal hangup*


(Bob) #2

When I dial in from outside and hit extension it goes straight to vm and from rss logs I get this…


#3

I have exactly that setup working for a long time. Asterisk behind a pfsense box with openvpn, cell phones with openvpn client and zoiper.
Even though this scenario would not be considered as a NAT environment, because the VPN avoids the NAT, zoiper does not work correctly if the extension is set to NAT=no, so you need to set it to NAT=yes, otherwise you have the one way audio issue. Make sure that you also add the VPN network to the local networks on the SIP settings page.


(Bob) #4

Thanks tried the NAT setting no avail the vpn is in the trusted area of firewall.

Maybe I will reboot FreePBX and see if that makes a difference


#5

You must add the VPN network in the SIP settings page.


(Dave Burgess) #6

Main Menu -> Advanced Settings -> SIP Settings Page


(Bob) #7

Here correct?

And thank you guys for taking the time to help with this issue.


#8

Settings -> Asterisk SIP Settings -> Local Networks. Add an entry for the VPN subnet.


(Bob) #9

Thanks guys so much that was it!! I have been fighting this for so long I am so happy. Stewart1, Cynjut, arielgrin I owe you guys a coffee seriously!!


(system) closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.