Speed dial and other feature codes on/for Cisco 'cheap' phones

FreePBX 12.0.2, but before upgrade it was the case as well…
My endpoints are a mix of SPA112, PAP2T (…yes) and SPA301, by Cisco.
I run this in Devices and Users mode.

I read the available advice (e.g. http://www.freepbx.org/support/documentation/howtos/how-to-set-up-a-linksys-pap2-or-sipura-spa-2000-for-use-with-freepbx but not only that) on how to get these to work and they mostly do.

However there is a problem with the following feature codes :
*0 = speed dial - when I dial this followed by the speed dial number, the endpoint reboots… (at least SPA112 does) (vertical service activation code is blank on the device and devices’ own service is disabled); I also tried changing default *0 to ‘something else’ - of the available feat codes - only to be greeted with 4 beeps that clearly come from the device because asterisk -vvvvr doesn’t move an inch;

*2 = attended transfer - seems to work from SPA112 and PAP2T, no effect on SPA301 (and nothing happens in asterisk -vvvvvr either when done so)
(blind transfer = ## - that does work)

I have speed dial functions module installed and enabled, trying to click on ‘get help for speeddial’ gets me http://wiki.freepbx.org/dosearchsite.action?queryString=speeddial

Is it my DTMF settings on either Devices and the devices themselves?

Thanks in advance for any pointers, even google keywords :wink:

I’m having the same problem with de speed dial, Did you solve the problem? Thanks.

I ended up with changing the *0 feature code to 000 ( *0 caused the SPA112’s to restart); and for it to properly recognize that a tone is to be sent to the pbx, the key needs to be held at least 0.5s or so (I set device/extension DTMF setting to SIP INFO and same on the SPA’s.)
(I admit I did not try the long-strokes with the *0 code; but then, when a speed dial is programmed into an analog handset connected with SPA112, i’ve no control over the speed/length of dial, so it’s better that way) Maybe there is some setting on SPA’s for that, but ‘it’s not too bad’ this way anyway.
Hope this helps.

I’ve solve it, you need to change the default Dialplan. The SPA112 recognize only *X; so you change it a get it working.

Before you need to stop the functions that can get override because the use *XXXX keys.

My dial plan:


I got this randomly on the internet.

1 Like