Spectra Link 8002 won't work

Does anyone know how to get the Spectra Link 8002 WiFi phone to work on Elastix or Trixbox. I’ve done everything by the book from Polycom, but I always get " no sip user file" on the phone and then it reboots, however the correct files are in the TFTPBOOT folder in my box.

The machine was built with a download from Elastix, and then upgraded using yum update.

The current asterisk version is 1.4.24
The free pbx version is
The Elastix version is 1.5.2-2
The files for the spectralink phone are 130.007

Have you looked at the tftp logs to see if the phone is even contacting the tftp server? Or verified that the tftp service is running?

Yeah, that’s working, I can see in there where it requested the files and the user file that has the name assoc. with the extension actually even shows on the display of the phone, the phone seems to think it’s registered, but it won’t make a call.

Well you are now contradicting what you said above “but I always get 'no sip user file” on the phone’ This would mean that the phone is asking for a file that it is NOT getting. either because it is asking for one that you don’t have or it is asking for a file from another source.

So based on you last statement you have that now working sorry I tried to provide info based on the state that you published.

So now at the asterisk cli after the phone is booted type: sip show peers
and review the list. Is the extension for the phone listed?

You should get a list something like this:

Name/username              Host            Dyn Nat ACL Port     Status    
789/789                    (Unspecified)    D   N      0        Unmonitored
141                        (Unspecified)    D   N      0        UNKNOWN   
148/148                D   N      5060     OK (1 ms) 
145/145               D          5060     Unmonitored

Extension 789 is a phone that used to be online and now is not anymore (has not been in several weeks).
Extension 141 was configured but has never been connected to.
Extensions 148 and 145 are both registered, connected and functioning just fine.

Sorry, you’re right about that, I did get from no sip user file to getting the phone to actually end up at an idle screen, and it did get the file, but it shows up just as your example extension 141 after “sip show peers”, so, it acts like it got what it needs, I can even go change the name in the sip_9303.cfg file that’s in my tftpboot folder on elastix and it will change the display of the phone. But I can’t make a call, and can’t see it actually register.

ok if it shows as my extension 141 then that phone has NOT communicated or registered with the server and asterisk. So while it might have gotten what was needed from the TFTP server to boot up it’s not communicating and registering with the server and the asterisk processes properly.

So you might not be providing everything needed to register with the server or providing the proper information (user name and password).

Most configurations need to know a few simple things.

  1. username
  2. password secret
  3. registrar server
  4. registrar server port
  5. proxy server
  6. Proxy server port

So it’s time to triple check those values as something is wrong and again you’ve not provided needed information for review so we can’t comment. 2. I have not worked with that phone so I can’t help but if you are patient maybe somebody else can, or the next place is to talk to the manufacture for some help as they would know the phone better then anybody.

Dear Dwayne,

I just received my Polycom 8002 yesterday and have spent several hours setting it up so I have most likely seen most of the messages that you have seen.:slight_smile:

Please verify that your Access Point has the WMM (Wi-Fi Multimedia) option somewhere under WLAN settings, SSID settings and that it is activated. I have seen several posts from other users confirming that Polycom requires WMM and it’s not optional.

The next hurdle was to input twice without error the passphrase which was a feat in itself the way Polycom displayed what was input. Hopefully you can test without that feature to ensure first that the unit works on your system.

Mine started to work correctly once I activated WMM.

Also make sure that your config file doesn’t have the extra settings that aren’t being used in it. I had the problem you’re describing and once I limited the config file to just in settings I needed (and a few comments) the phone fired right up.

I´ve a similar issue. I can check on tftp log and see it fails when downloading only sip files. Then restarts.

It says this:
Connection received from on port 20000 [06/01 12:19:24.853]
Read request for file <sip_allusers.cfg>. Mode octet [06/01 12:19:24.868]
Using local port 2511 [06/01 12:19:24.868]
TIMEOUT waiting for Ack block #20 [06/01 12:19:28.837]

Connection received from on port 20002 [06/01 12:19:33.087]
Read request for file <sip_1304.cfg>. Mode octet [06/01 12:19:33.087]
Using local port 2512 [06/01 12:19:33.087]
TIMEOUT waiting for Ack block #20 [06/01 12:19:40.087]

Other files (slnk_cfg.cfg and bin files) get downloaded ok. In both cases the tftp server shows that there are 9728 Bytes sended to phone.

any idea?