Spawn extension

Hello i got a new message in asterisk -rvvv when i was monitoring it said == Spawn extension (from-sip-external, h, 1) exited non-zero on Not sure what that is. Can someone help me out please?

Now i get a new message – Executing [[email protected]:1] Hangup(“SIP/xxx.xxx.xxx.xxx-00000009”, “”) in new stack

GIve the following commands in asterisk cli and see if someones registers remotely

sip show peers

i get this message

Name/username Host Dyn Forcerport Comedia ACL Port Status Description
700/700 000.000.000.0000 D Yes Yes A 1024 OK (21 ms)
1 sip peers [Monitored: 1 online, 0 offline Unmonitored: 0 online, 0 offline]
localhost*CLI>

looks like the only one that is there is mine that i have setup

So I’m guessing I’m safe? But where does that come from? server on a Vps hosted server.

Maybe you allow to receive anonymous sip calls, check your /var/log/asterisk/full file to see if your box have received a call or any other “weird” behaviour.

Hello yes i have seen something in there says Answered and hangup but wasn’t me. I don’t have a phone here at home. How do i turn off anonymous sip?

i went into Asterisk Sip settings and see this Allow Anonymous Inbound SIP Calls - no

now when i look i get this message in there

– Executing [[email protected]:1] NoOp(“SIP/xxx.xxx.xxx.xxxx-00000019”, “Received incoming SIP connection from unknown peer to 9011972597619372”) in new stack
– Executing [[email protected]:2] Set(“SIP/xxx.xxx.xxx.xxxx-00000019”, “DID=9011972597619372”) in new stack
– Executing [[email protected]:3] Goto(“SIP/xxx.xxx.xxx.xxxx-00000019”, “s,1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/xxx.xxx.xxx.xxxx-00000019”, “0?checklang:noanonymous”) in new stack
– Goto (from-sip-external,s,5)
– Executing [[email protected]:5] Set(“SIP/xxx.xxx.xxx.xxxx-00000019”, “TIMEOUT(absolute)=15”) in new stack
– Channel will hangup at 2016-06-19 05:06:41.252 EDT.
– Executing [[email protected]from-sip-external:6] Log(“SIP/xxx.xxx.xxx.xxxx-00000019”, "WARNING,“Rejecting unknown SIP connection from 23.239.65.46"”) in new stack
[2016-06-19 05:06:26] WARNING[23043][C-00000019]: Ext. s:6 @ from-sip-external: “Rejecting unknown SIP connection from 23.239.65.46”
– Executing [[email protected]:7] Answer(“SIP/xxx.xxx.xxx.xxxx-00000019”, “”) in new stack
== Spawn extension (from-sip-external, s, 7) exited non-zero on ‘SIP/xxx.xxx.xxx.xxxx-00000019’
– Executing [[email protected]:1] Hangup(“SIP/xxx.xxx.xxx.xxxx-00000019”, “”) in new stack
== Spawn extension (from-sip-external, h, 1) exited non-zero on 'SIP/xxx.xxx.xxx.xxxx-00000019’
localhost*CLI>

Is this ip yours? It is from Jacksonville

https://who.is/whois-ip/ip-address/23.239.65.46

It seems like someone is trying to dial in your box but you have enabled anonymous call rejection in your FreePBX. I would investigated a little more if I were you. The weird thing is how the call ends in the from-sip-external context. Is it a custom context that you have created? Is it configure in any of your sip trunks?

Hello this is a brand new installation. i have not created no no custom context . I have never learned how to do that yet. here is a image

Allow guests needs to be set to no as well. It’s in the same area

1 Like

Hello Tm i just found it thank you.

Astbox no mine is not mine is the one that says xxx.xxx.xxx.xxx i just blocked mine in here so it doesn’t show. The other person who is trying to come in is there ip address.

Heh I couldn’t remember the option, thaks @tm1000. @josephchrz set this option and I think you are good.

Yes looks like I’m good now whoever it is now stopped thank god LOL. Thank you. Now if i can figure out my last problem i’ll be set i posted how can i setup my cisco-9971 but so lost now.