SPA504g phones one hour fast

System time on the server is correct. The SPA504g phones are an hour fast.

I’ve not altered the default $model.cfg file, which shows these time-related entires:

<Set_Local_Date__mm_dd_ ua=“na”></Set_Local_Date__mm_dd_>
<Set_Local_Time__HH_mm_ ua=“na”></Set_Local_Time__HH_mm_>
<Time_Zone ua=“na”>GMT-08:00</Time_Zone>
<Time_Offset__HH_mm_ ua=“na”></Time_Offset__HH_mm_>
<Ignore_DHCP_Time_Offset ua=“na”>Yes</Ignore_DHCP_Time_Offset>
<Daylight_Saving_Time_Rule ua=“na”></Daylight_Saving_Time_Rule>
<Daylight_Saving_Time_Enable ua=“na”>Yes</Daylight_Saving_Time_Enable>

Perhaps related, I’ve altered the display name on one of the phones in question and it doesn’t change on the phone. I do have option 66 set in DHCP and pointed to the FreePBX server.

The one Polycom speakerphone is also an hour fast.

CDR and voicemail recordings list correct time.

FreePBX Distro is current (as of today), and all modules are current as of today.


Pertinet to DST:

<Primary_NTP_Server ua=“na”>{$ntp}</Primary_NTP_Server>
<Time_Zone ua=“na”>{$timezone}</Time_Zone>
<Daylight_Saving_Time_Rule ua=“na”>start=3/8/7/02:0:0;end=11/1/7/02:0:0;save=1</Daylight_Saving_Time_Rule>
<Daylight_Saving_Time_Enable group=“Regional/Miscellaneous”>Yes</Daylight_Saving_Time_Enable>

Just an idea, change dhcp time-set to <Ignore_DHCP_Time_Offset ua=“na”>No</Ignore_DHCP_Time_Offset> and then add the following to your dhcpd.conf

option time-offset -28800; (assuming I got that right–I’m in central time zone)
option ntp-servers;
option time-servers;

then reboot a phone with the updated xml file to see if that fixes it.