SPA3000 with FreePBX 15

Does anyone have a complete setup of FreePBX 15 with an SPA3000 ?

Can you please share screen shots of the correct options in both the SPA and FreePBX


Start here: spa3000 freepbx configuration - Google Search

Thats rhe first thing I tried, everything I found was for older versions of freePBX and i tried playing around with ports because they are completely different in the 15 but nothing worked i am unable to get the SPA to register.

For testing, do not use registration. Remember that the FXO’s UDP port is 5061.

Also tried that and didnt work… :frowning:
If you have steps by step configurations that would be great.

You’re dealing with a device that is over 20 years old. Support for it was discontinued in 2005. Bite the bullet and buy something like the Grandstream HT813 for around $50 and enter the modern world with a device people currently use and support.

Take this one step at a time, starting from SPA reset to defaults:

  1. Create a pjsip extension. You don’t need to make any settings other than the extension number, Secret and Outbound CID. Choose a secret containing no more than 12 letters and digits.

  2. On the SPA Line 1 tab, set Line Enable: yes; Proxy: (replace with the IP address of your PBX, replace 5060 with the value of Port to Listen on in Asterisk SIP settings); Display Name: (as desired); User ID: (extension number); Password: (same as Secret for the extension); Dial Plan:

  3. SPA Info page should show Line 1 as Registered. Pick up attached phone, you should be able to call *43 (echo test), any other extensions on your PBX, outside numbers (if you have a SIP trunk set up). Other extensions should be able to call the phone. If any of this doesn’t work, provide details.

  4. Create a pjsip trunk named SPA3000. Set Outbound Caller ID: (phone number); CID Options: Force Trunk CID; Secret: (no more than 12 letters and digits); Authentication: Both’; Registration: Receive; Match Inbound Authentication: auth username; Rewrite Contact: Yes; Force rport: Yes.

  5. On the SPA PSTN Line page; set Line Enable: yes; Proxy: (same as for Line 1); Register: yes; Display Name: (as desired); User ID: SPA3000; Password: (same as Secret for the trunk); Dial Plan 2: (<:2345678>S0) (replace 2345678 with phone number and note that the parentheses are needed around the dial plan); VoIP -To-PSTN Gateway Enable: yes; VoIP Caller Auth Method: HTTP Digest; One Stage Dialing: yes; VoIP Caller Default DP: 3; VoIP User 1 Auth ID: SPA3000; VoIP User 1 DP: 3; VoIP User 1 Password: (same as Secret for the trunk); PSTN-To-VoIP Gateway Enable: yes; PSTN Caller Auth Method: none; PSTN Ring Thru Line 1: no; PSTN CID For VoIP CID: yes; PSTN Caller Default DP: 2; Off Hook While Calling VoIP: no.

  6. At this point, PSTN Line should be registered. There are likely some settings missing or incorrect, so please report what happens on incoming and outgoing calls. Also, report:

What country are you in? What is the FXO port connected to (copper pair from CO, cable MTA, fiber ONT, etc.)? What is the range of extension numbers on the PBX? Do you dial a prefix such as 9 or 0 before external numbers (not recommended)? Post screenshots of relevant settings pages.

1 Like

Easier said than done, I live in a country that is under occupation where we can’t just go and buy whatever we want. Technology is monitered and regulated we only got 3g last year and we still have 2g networks.
Telephony devices are highly regulated so we need to work with what the world considers as obsolete.

Thank you very much stewart. I will follow your instructions and see what I can come up with.

I had a SPA3000 working with FreePBX 15 & 16 (till it decided to die). I do remember that configuring as a trunk caused all sort of problems so yeah, set it up as an extension (or two, one for each port). Only UDP is supported so what stewart said should be correct.

You sir are a hero. Thank you so much

The settings you provided worked perfectly, instant registration.

The 2 things that I had to change was add an outbound route to get my SIP phone to dial external numbers and set the SPA PSTN Answer Delay:2, instead of the default 16

I just have 1 issue to look into, when an outside number dials in, the SIP phone shows the PJSIP extension number and display name instead of the actual number calling in. (I will play around with the settings to try to fix that and post an update.)

Extension to extension works.
Extension to external works.
External to Internal extension works.

I live in Palestine (not the one in Texas).
The FXO port is connected to a copper pair.
The range of extensions starts from 2000.
No prefix needed.

First, confirm that the SPA is correctly reading caller ID info from the analog line. After making a test call in, look at the SPA Info page for Last PSTN Caller. If the number shown is not correct, try changing PSTN Answer Delay to 4 and retest. If that doesn’t help, try changing Caller ID Method and/or Caller ID FSK Standard to match what is used by your carrier. Sorry, I don’t know what the standard is for Palestine. If you can’t find it, you may have to experiment. If you have a way to listen on the line without answering (butt set, capacitor in series with headphone, etc.), you should be able to at least distinguish FSK from DTMF.

Once Last PSTN Caller shows the correct number, if you still have trouble, at the Asterisk command prompt type
pjsip set logger on
You should see the calling number in the From header of the INVITE sent from the SPA to the PBX, and then in the INVITE sent from the PBX to the called phone.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.