SPA3000 as trunk

I am trying to get a cisco SPA3000 to register to make out going calls. I have two cisco SPA phones and a polycom phone. I can’t get the PTSN line to register, It just keeps saying ‘failed’ at the registration status. I have followed the instructions at, but cant get it to work. The phone just says while trying to dial outwards "all circuits are busy now’ ‘please try your call again later’. The last step ‘17. Setting up the outbound route, works like any other outbound route, you make a dialplan, select the trunk to be used for any calls matching it, and apply.’ does not make sense to me as a newbie. thanks in advance for any help

The wiki example is using chan_sip for the trunk, which listens on port 5160 by default.
On the SPA’s PSTN tab, change Proxy to read
(replace with the actual LAN IP address of your PBX).

Also, it’s inconsistent about registration. In the trunk settings, remove
and replace

With luck, the SPA should register and you should be able to receive calls. To make calls, you need an Outbound Route. If the SPA is the only trunk on your system, you can just use
for the match pattern and put your trunk in Trunk Sequence for Matched Routes.

If you still can’t register, what (if anything) appears in the Asterisk log on the registration attempts?

If it registers but you still have trouble, post a log of a failing call (two calls, if both incoming and outgoing are failing).

Thanks stewart. I will be trying this tonight.

Thanks stew! I got it to work with your instructions. I can make calls from my Cisco IP phones. However I can’t seem to make incoming calls to the Cisco phones. It rigs about three times then does a busy tone. I have made a inbound route changing nothing expect the DID number as my phones line number. I have the destination set to the phone i have in my room (220) but the phones does not ring

Does 220 ring when called from another extension? If not, fix that first.

Try temporarily setting the DID Number field for the Inbound Route blank (which means ANY). If that works, there is a mismatch between what the SPA is sending and what the route is expecting.

In the SPA, try setting PSTN Answer Delay to 4.

If no luck, see what, if anything, appears in the Asterisk log on a failed call. If you see activity but can’t interpret it, paste the relevant section at and post the link here.

If there is no activity, post a screenshot of the PSTN Line tab (in Advanced mode). Also, if the Line port is connected to other than a copper pair from the central office, please post details (cable MTA, fiber ONT, Vonage box, magicJack, etc.) When you hear the busy tone, has the line been ‘answered’ (e.g. if calling from your mobile, does it show connected and start counting time)?

I have changed those setting as you described, there was no change expect how quickly the line goes to busy. Also the line has answered when thee busy tone is prompted to the caller.
Here is a link the my logs
The line is a phone line provided by spectrum, its comes out of the modem

If your logging was done correctly (the test call was made after the last Apply Config and you posted through the end of the log), then the call didn’t hit the PBX at all.

Please post a screenshot of the PSTN Line page. Make a test call, refresh the Info page while the busy tone is playing, and post a screenshot of that. Also, approximately how long does it take from when you first hear ringback tone on the calling phone, until the busy tone starts?

Here are screen shots of my PSTN tab

not sure how to preform a test call

PSTN Caller Default DP should be 2.

With luck, you will at least get something logged on an incoming call.
If not, refresh the Info page while the busy tone is playing, then post a screenshot.

That worked! I guess luck was on my side. Thanks very much

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.