Spa122 Not loading spa$MA.xml

I have been trying to config an SPA122 using EPM to be able to config both Lines 1&2. Basically the way I understand this is supposed to work is the “Profile Rule” gets the spa$PN.cfg (which changes to spa122.cfg) and the file is present. which then replaces the the “Profile Rule” with:

<Profile_Rule>[–uid 999999999 --pwd aaaaaaaaaaaaa] http://xxx.xxx.xxx.xxx:84/spa$MA.xml</Profile_Rule> and then performs a resync after 3-5 seconds.

I am using:

  • PBX Version: 15.0.17.64
  • PBX Distro: 12.7.8-2107-3.sng7
  • Asterisk Version: 16.19.0

Does this work?? I have been trying to get this going now for several hours and unless I hard code the proxy/User/password for the lines, it won’t work.

Appreciate any input.

Thanks Ed

I have run into this too but not just on FreePBX. This seems to be an issue with the SPA112, probably a bug that isnt getting fixed.

Thanks for the reply. This is a SPA122 and I applied the FW1.3.x and 1.4.x and continued to have the same issue. It appears the SPA returns a Bad Request (400) Your browser sent a request that the server could not understand. after the successful 200 return code on the initial command.

Hate this ATA’s but they are a cheap solution to a temporary problem - guess I will do it the hard way unless someone has an alternative option.

Thanks,
Ed