SPA112 No ringing when making outgoing calls but connects

configuration
Tags: #<Tag:0x00007f7022fd1d78>

(Defcomllc) #21

My personal opinion, there is a setting in the SPA112 that needs to be changed, because Ringback works correctly on all IP phones running on the PBX. Yes, I did upgrade the SPA112 firmware to the latest before installation. I will try another cordless phone (vtech) I have here to see if this wireless phone is the issue… I dont have a corded analog phone but I could easily order one to test they are cheap.


#22

Please try this test:

Create a new pjsip extension. Leave everything at default except the extension number.

Set up Line 2 of the SPA to connect to the new extension. I believe that the only settings you need to change from default are Proxy (192.168.20.10:5966), User ID (the new extension number) and Password (copy the Secret generated for the new extension).

With luck, it will register. Plug the VTech phone into Phone 2 on the SPA and test.


(Defcomllc) #23

Alright I just did exactly that. I created a brand new default settings pjsip extension. All I did was give it an extension and name. I setup Line 2 on the SPA112 with the new extension and plugged the vtech analog wireless base into Line 2 on the SPA.

I just made an outgoing test call to my cell phone…exact same issue. Dead air silence till my cell phone starts ringing. I answer my cell phone and and can hear 2 way convo perfectly fine.


#24

OK, let’s try a few simple things. If they fail, capture traffic and see whether the early media (before answer) RTP being sent to the SPA has ringing sound.

On the SPA SIP page, set RTP Packet Size to 0.020 and for the Line being tested, set both G729a Enable and G726-32 Enable to no. For the extension, set Disallowed Codecs to all, Allowed Codecs to ulaw and retest.


(Defcomllc) #25

Alright, made those suggested changes and same result. No ringback but call goes through to my cell…

Sorry, not familiar with doing tcpdump. Can you tell me how to do that.


(Defcomllc) #26

So I SSH into my freePBX, i ran the following command

tcpdump -s0 -w/tmp/capture.pcap -C50 udp and port 5699

And I got a message saying NFLOG link-layer type filtering not implemented…I then made a call again… then hit CTRL+C but there is no file called capture.pcap in the TMP folder when I FTP into freePBX…

I probably have the wrong command ?


#27

I don’t know what is wrong. Try just
tcpdump -w capture.pcap
make a test call, type control-C (should show count of packets captured) and look for capture.pcap in the current directory.


(Defcomllc) #28

Ok, I ran that command and that took… I made the test call from the analog phone then hit Ctrl+C on my keyboard. It said 0 packets received by capture??? and I dont see a capture.pcap file in the TMP directory. Am I looking in the right directory or should I be looking somewhere else for it?? (See below screenshot)

Imgur

Imgur


#29

Somehow the default device is strange. Try
tcpdump -i eth0 -w capture.pcap
(replace eth0 with the name of your Ethernet device if different).


(Defcomllc) #30

Alright that worked. Says it captured packets…But… i still dont see the capture.pcap in /tmp… Am I looking in the right directory? Where should it be?

image


(Defcomllc) #31

Alright, after doing some research online, I ran this command, did the test call from the analog handset connected to the SPA and the capture.pcap showed up in /tmp

tcpdump -i eth1 -w -p -n -s 0 udp > /tmp/capture.pcap


(Defcomllc) #32

Ive never used WireShark before. I have it installed, and I opened the file in Wireshark but it shows nothing…It wants me to “Apply a display filter”???


(Defcomllc) #33

Alright I finally got it working, here is the tcpdump in WireShark. Changed up my tcpdump to the following and now the capture.pcap opens in wireshark

Not sure what to look for or what to do next. I really appreciate all your help with this.

tcpdump -i eth1 -w /tmp/capture.pcap


(Defcomllc) #34

Here is the WireShark of the actual call I placed with the Analog phone to my cell


#35

Select an RTP packet going to the ATA, e.g. No. 176. Then select Telephony -> RTP -> Stream Analysis.
Click Play Streams. Click the stream with Destination Address 192.168.20.11. Click the play button.


(Defcomllc) #37

Ok I did that. I hear my cell phone ringtone in the background, then I hear me answer and talking… But no ringing before I pick up…

When I pick #171 and Analysis and listen its dead silence for a while then at the end I answer the call and you hear me talking… Thats exactly what I hear when I use the analog phone. Silence and then someone answers on the other end and we can talk fine…


#38

Wow, that is the stream from the carrier (Bandwidth), so it’s not the PBX messing with the audio.

Somehow, when you call from the ATA, the INVITE sent to SIPStation (and ultimately to Bandwidth) must be different in a way that causes the early media to be silent. I’ve never seen anything like this before. Can you post the capture file here? Rename it to capture.tgz and the forum will let you upload it, even though it isn’t actually a .tgz file.


(Defcomllc) #39

Hmm I right clicked on the file, rename and added .tgz but when I upload it still says file type not allowed…


(Defcomllc) #40

here get it this way and then I will delete this link

https://netorg272580-my.sharepoint.com/:u:/g/personal/deachus_defcomllc_com/EX3MyucXipBLilh-slzkvX0Bza-jhnqqRaNfpzhWqhn0sg?e=RDeitD


#41

Thanks. The audio from Bandwidth is all zeros (not even the usual low level noise) until ~300 ms after answer.
Unfortunately, I can’t think of what could possibly cause that, given that it works fine from your other extensions. Could you post a capture of a call to your cell from a working extension for comparison?

How are you connected to FiOS? Is the Ubiquiti router connected directly to the ONT? If not, please provide details. Does the Ubiquiti have a SIP ALG enabled? If so, have you tried turning it off?

I could try calling your cell from here and view the capture (I don’t have SIPStation but can force AnveoDirect to use Bandwidth for the call). Is that ok?