Can anyone tell me why I am getting this error?
The user name and secret are the same in the spa-3000 and match the trunk settings.
The only difference I can see is the ports.
The spa-3000 uses port 5060 for line 1 (that works fine)
Port 5061 is used for the PSTN.

[Apr 7 19:00:38] NOTICE[1785] chan_sip.c: Registration from ‘PSTN sip:[email protected]’ failed for ‘’ - Wrong password
[Apr 7 19:00:38] SECURITY[1749] res_security_log.c: SecurityEvent=“InvalidPassword”,EventTV=“1396861238-445196”,Severity=“Error”,Service=“SIP”,EventVersion=“2”,AccountID=“pstn”,SessionID=“0xb72292ac”,LocalAddress=“IPV4/UDP/”,RemoteAddress=“IPV4/UDP/”,Challenge=“66d4fbd5”,ReceivedChallenge=“66d4fbd5”,ReceivedHash=“66428e6befa1771c61bbab6e3675e2dd”

Any help please
Regards Phil

When assisting with issues like the one you are experiencing it is helpful to have a bit more info.

What version of FreePBX?
Distro or hand built?
Configuration of the SPA and FreePBX?

The system is in Australia
System is running FreePBX Distro
Asterisk 11.8.1
SPA-3000 has been setup using the instructions in howto SipuraSPA-3000
With only one change from recommended. That is RTP packet size. It has been left at .030 the recommended setting .020 does not work.

If the SPA-3000 is set to .020 you get one way audio and no CID info sent to the phone. Set to .030 you get excellent 2 way audio and CID works fine.

Even with the error wrong password being reported.
Calls are received from the SPA-3000 PSTN trunk on port 5061 without a problem and are forwarded via FreePBX to the extension on the SPA-3000 Line 1 using port 5060.