Sound Languages is empty

We recorded some Holiday messages in System Recordings OK prior to Christmas. After the holidays we wanted to add a new recording but on the System Recordings page there is now a banner saying “You have no sound packages installed in the Sound Languages module. Please install at least one language to use System Recordings”. So we can’t make any new recordings.

Going to Sound Languages displays a blank page, with just the fly-out menu on the right. Selecting Language Packs also displays a blank page.

Looking in /var/lib/asterisk/sounds/en shows that the directory is populated with the sound files, but if I go into settings in Sound Languages there are no dropdown options for the Global Language.

Current Asterisk Version: 13.11.2
Sound Languages 13.0.23.6

I have tried using “fwconsole ma downloadinstall soundlang” but no change

Appreciate any suggestions on how to resolve?

Thanks,

Uninstall sound languages and reinstall

Is this a distro machine?

Yes, it is a distro install.

I was considering a reinstall of the module but there is a long list of dependent modules that need to be disabled first. I’ll try it this evening.

Thanks,

fwconsole ma uninstall soundlang --force
fwconsole ma install soundlang

I tried the above but no change. I then went through and disabled all the modules required until I could use

fwconsole ma remove soundlang
fwconsole ma downloadinstall soundlang

then re-enabled everything but still no change.

I don’t believe there are any internet connectivity issues with the server but is connectivity required for the soundlang module to function (even for the basic en languages)? If so, what web address could I check to confirm connectivity?

Thanks,

The blank page is most disturbing. Please send a screenshot.

Screenshots below and /var/lib/asterisk/sounds/en still has sound file contents.

I just took a look through freepbx.log and found these entries, they seem to coincide with when I tried accessing Sound Languages:

[2017-Jan-12 19:11:07] [ERROR] (soundlang/Soundlang.class.php:1193) - Failed to get remote file, error was:
[2017-Jan-12 19:11:07] [ERROR] (soundlang/Soundlang.class.php:1193) - Failed to get remote file, error was:

Seems you have a firewall blocking server access

Can you give me an address I could try to wget to confirm?

The following worked successfully so I don’t believe it’s a firewall problem.

[[email protected] ~]# wget https://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-1.sh
–2017-01-12 19:59:11-- https://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-1.sh
Resolving upgrades.freepbxdistro.org… 199.102.239.49
Connecting to upgrades.freepbxdistro.org|199.102.239.49|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 21306 (21K) [application/x-sh]
Saving to: âupgrade-10.13.66-1.shâ

100%[======================================>] 21,306 90.6K/s in 0.2s

2017-01-12 19:59:13 (90.6 KB/s) - âupgrade-10.13.66-1.shâ

[[email protected] ~]#

Thats not the same server. The error message above says it can’t hit the server

How do I determine the address of “the server”?

I’ve demonstrated that my server can access “a server” so while it’s possible that a firewall rule may be blocking some specific addresses (which I’ve determined for my site, to the best of my ability, that it isn’t) I can’t progress without knowing the address that is being blocked.

Your server is blocking the normal mirror URLs.

mirror1.freepbx.org and mirror2.freepbx.org

soundlang v13.0.24.1 should give you more verbose errors and also let you continue to create a custom package if you can’t connect

Thanks for the links, I’ll check them and respond.

I get the following from attempts to wget a random url:

[[email protected] ~]# wget http://mirror1.freepbx.org/xyz
–2017-01-13 09:19:45-- http://mirror1.freepbx.org/xyz
Resolving mirror1.freepbx.org… 199.102.239.170
Connecting to mirror1.freepbx.org|199.102.239.170|:80… connected.
HTTP request sent, awaiting response… 404 Not Found
2017-01-13 09:19:46 ERROR 404: Not Found.

[[email protected] ~]# wget http://mirror2.freepbx.org/xyz
–2017-01-13 09:20:05-- http://mirror2.freepbx.org/xyz
Resolving mirror2.freepbx.org… 162.253.134.144
Connecting to mirror2.freepbx.org|162.253.134.144|:80… connected.
HTTP request sent, awaiting response… 404 Not Found
2017-01-13 09:20:06 ERROR 404: Not Found.

So it doesn’t look to be a firewall problem. If there’s a more specific url I should test then I’m happy to do so.

Module Admin “Check Online” completes successfully although isn’t offering any updates at present on this server. There are no error entries in freepbx.log following the Check Online.

I guess I could try and create a custom “en” language given that the sound files exist. Alternatively it looks like a server rebuild.

Well try to use the new sound lang module and see what it says now

EDIT: ignore the below errors, sorry, I was inadvertently still in the manually downloaded soundlang module directory when I ran the upgrade command and it seems to have been using files from there, not sure what happened.

I re-ran the upgrade command from the /root directory and it completed successfully but after Apply Config the version number in Module Admin has not been updated.

===============================================================

I ran the upgrade command as below but it gave error messages. After Applying Config the soundlang version wasn’t updated in Module Admin.

I’ve downloaded the zip of the new version from Github but google won’t guide me to a description of how to manually install a module from a zip file.

[[email protected] soundlang-release-13.0]# fwconsole ma upgrade soundlang
No repos specified, using: [standard,commercial] from last GUI settings

Starting soundlang download…
Processing soundlang
Verifying local module download…Verified
Extracting…Done
Module soundlang successfully downloaded
Generating CSS…Done
Module soundlang successfully installed
Updating Hooks…PHP Fatal error: Cannot redeclare class ComposerAutoloaderInitb728baa7356d963458db110c835e9594 in /root/soundlang-release-13.0/vendor/composer/autoload_real.php on line 6
Whoops\Exception\ErrorException: Cannot redeclare class ComposerAutoloaderInitb728baa7356d963458db110c835e9594 in file /root/soundlang-release-13.0/vendor/composer/autoload_real.php on line 6
Stack trace:

  1. () /root/soundlang-release-13.0/vendor/composer/autoload_real.php:6
    Updating Hooks…PHP Fatal error: Cannot redeclare class ComposerAutoloaderInitb728baa7356d963458db110c835e9594 in /var/www/html/admin/modules/soundlang/vendor/composer/autoload_real.php on line 6
    Whoops\Exception\ErrorException: Cannot redeclare class ComposerAutoloaderInitb728baa7356d963458db110c835e9594 in file /var/www/html/admin/modules/soundlang/vendor/composer/autoload_real.php on line 6
    Stack trace:
  2. () /var/www/html/admin/modules/soundlang/vendor/composer/autoload_real.php:6
    [[email protected] soundlang-release-13.0]#

You need to upgrade using edge

–edge

1 Like