Sonicwall pbx route issue


(Matthew Rabone) #1

I have a site to site vpn set up between site b connecting to main site a

Site a hosts the pbx server on a lan 192.168.30.X gateway is 192.168.30.1

Pbx server has address of 192.168.30.252 it has a separate 3rd party gateway of 192.168.30.253

Problem
I can’t ping the box server from site b I can ping all other devices on the lan at site a from site b but not the pbx server.

I assume this is due to the difference in gateway which I can’t change but how can I resolve this some sort of static route?


(Dave Burgess) #2

I don’t have a specific solution for you, but this thread might at least get you connected to the right sub-culture. Happiness With Sonicwalls - It can happen!


(Greg Snover) #3

That’s not a SonicWALL issue - that is a simple Static Route:

https://my.esecuredata.com/index.php?/knowledgebase/article/2/add-a-static-route-on-centos

Add a route specifying the gateway that allows access to the remote subnet, and you are good.


(Matthew Rabone) #4

Thanks Greg

So how would that look in this case

So my users are at Site B on range 192.168.33.x

Site A is on 192.168.30.x with Gateway of 192.168.30.1 PBX server is on 192.168.30.252 routing out via gateway of 192.168.30.253

The two are connected by site to site vpn

What route would I add would it look something like this?

ip route add 192.168.33.252 via 192.168.33.0 dev eth0


(Greg Snover) #5

Other way around:

ip route add 192.168.33.0/24 via 192.168.30.1 dev eth0

So you are telling the Asterisk how to get to the complete 192.168.33.x subnet via the router that allows access to that subnet.


(Matthew Rabone) #6

ahhh sorry i’ve just realised i may have omitted som relevant information,

the pbx system is running in a vm on nethserver pbx vm ip 192.168.30.252 nethserver 192.168.30.19
would i run the above command on the nethserver 192.168.30.19? or on the Asterisk .252 or both

also its running as bridged connection so the adapter is br0 not eth - just edit to say ip route add 192.168.33.0/24 via 192.168.30.1 dev br0?

i’m about to make the change, quick what is the command to back it out if any problems?


(Greg Snover) #7

From the article above:

Add a permanent static route

To make the route permament, you need to create a static route configuration file. Create a file with the name route-interface in /etc/sysconfig/network-scripts, such as:

nano /etc/sysconfig/network-scripts/route-eth0

Or whatever interface you are using - routing for Asterisk has to be done on Asterisk.


(Matthew Rabone) #8

ok i have added the above route Greg, thank you i can now ping the server from site b.and the softphone is connecting

the issue i now have is when a call is made there is no audio on either end?

if i test using vpn from site b (open vpn not site to site) it works fine, but obviously i’m trying to use with site to site so we don’t have to use open vpn.


(Greg Snover) #9

Under SIP Settings on the PBX, you have to add the remote Subnet as a local Subnet - otherwise, the Asterisk tries to do NAT translation - and you get no audio.


(Matthew Rabone) #10

Greg… Once again you have saved the day, a true hero of the forum, a million thank you’s to you sir.


(Greg Snover) #11

No problem.

As you get more experience with the various issues with FreePBX (and really, Asterisk in general) and you see questions here that you can answer, go for it - Everyone is at some stage in the process of learning all the various things that go into getting an install working - help where you can and the whole community benefits.


(Matthew Rabone) #12

I will do Greg, be great to give something back to the community.


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.