Something broke after update

I carried out a module update on Friday which lost a phone on my system and also wont let me login to fix it.

All i get if I browse to the ip address of my FreePBX server is

‘Error, no line key set for Cisco Enterprise phone’

on a white screen and nothing else, whilst doing the upgrade I did notice that the endpoint manager was being upgraded.

I’d suggest doing a factory reset on the phone, see if that fixes it. Otherwise, it’s broken!

Xrobau, this isnt on the phone. Sorry just read my post again and it looks as if i am talking about a phone.

The phones fine the above message is displayed on my freepbx server when i type the IP address in.


The error is because the template you have the Cisco Enterprise phone setup for, does not have a line key provisioned. Cisco’s will not load the config if there is not a line key set.

Why you are getting it trying to get to the page is strange. It might be a cache issue. Can you try a different browser or computer?

Its not a cache issue as it shows of 3 separate machines, with firefox, chrome and internet explorer.

This system has been running for well over 12months with the cisco phone and its only done this after the last endpoint manager upgrade. If it could get in to the system i would change the line key.

Any ideas how to access and make changes when I cant use the web interface ?

Got in, went though history of browser http://PBX/admin/config.php?display=extensions and deleted phone.

Thing is a working cisco phone that has sat here for 3 years now does not work after an upgrade, tried to configure it again but wont connect to PBX. Had this with polycom IP500 phones on a previous upgrade. But its a first that you can get in via the GUI if something is wrong.

This same problem has just happened to me.
I added an ext with a Cisco phone as it’s endpoint… but now I can’t see the web gui. Every page redirects to: "Error, no line key set for Cisco Enterprise phone.

Tried going directly to the extensions page and can’t.

Anyway to delete an extension via the CLI?

nevermind… oddly I waited about :30 mins and I was able to get back into the gui… and immediately went to the EPM and added a line for that phone. O_o

Just FYI. This web error still exists. If I remove the Cisco phone model from the EPM brand template, it still returns the “Error, no line key set for Cisco Enterprise phone” error and I can’t move forward. If I add back the phone model to the brand template and add a line, I still get the same error.

Unfortunately the way I had to resolve this was to delete all phones in EPM that were using a Cisco brand template, remove the models from the brand template, and manually edit the cfg files in /tftpboot

Additionally, EPM doesn’t load the firmware correctly for these phones, I’ve had to manually upload the Cisco SIP firmware files and modify the XMLDefault.cnf.xml file to reference the firmware load files.

Is there going to be any further development for EPM to work with Cisco Enterprise phones? or has that ship sailed?

As Stated in our wiki on EPM supported devices for over 3 years now Cisco is not certified or officially supported and you actually violate their EULA using their phones outside EPM withiut a special license from them. So no it’s not something we actively support or will be ever adding anything for. Ita beat effort.