Some Problems with a public FreePBX instance

configuration
Tags: #<Tag:0x00007f24c62cec40>

#22

I already tried all NAT Options and always did a “fwconsole restart”.
But Problem keeps the same, with another SIP Client its working fine


#23

OK, so let’s debug with this one. It’s obviously reassembled from (at least) two packets, because frame 248 is only 66 bytes and the SIP/SDP is much larger, though less than 1000 bytes.

What is the size of the preceding packet (more specifically, the packet containing the first fragment)? If it’s ~1514 bytes (like in your earlier post), take a look at the hex to see what junk it is filled with, which may be a clue as to what’s wrong. Also, where was this capture done? If at the far (PBX) end of the VPN, the VPN could be causing the trouble; check a capture at the PhoneSuite end.

I doubt that PhoneSuite would have itself generated fragmented packets, but possibly the OS it’s running under somehow got a small MTU value (as a result of the VPN).

Although I don’t believe it is in violation of the RFCs, sending both Authorization and Proxy-Authorization headers is very unusual and bloats the packet by ~100 bytes. I’m sure that Zoiper doesn’t do that. Possibly, the MTU value is such that Zoiper’s packet gets through unfragmented but PhoneSuite’s doesn’t.


#24

The trace is done on the PhoneSuite side (Windows 10).
But I already tried different Windows Systems, always the same problem, with VPN or a direct connection over the Internet.
So the MTU is for ZOIPER and PhoneSuite the same.

But I will take a look at the HEX

Thank you :slight_smile:


#25

The Company behind PhoneSuite gave me a new fixed version which reduced the SIP Header size.

Now everything is working fine.
Thank you all for your help


(system) closed #26

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.