Some newbie questions. Please help

So far, I have done the following:
Installed AsteriskNow (Asterisk 11.3that comes with FreePBX. I have installed a Digium Hardware with some FXO ports.
Connected a phone line to one of the FXO ports.
Reset the admin password of FreePBX.
Updated/upgraded modules.
Installed Digium Phone Module for Asterisk (DPMA) add-on and set the country code for dial tone to India.
Added an extension named 1000 with outbound CID field set as my PSTN line number and a password. (left all other fields as default).
Added an Inbound Route linked with my extension 1000 with all defaults.
Added a DAHDI trunk with Max Channel set to 1. (Left all other fields as defaults)
Added an Outbound Route that uses the new DAHDI trunk.
Installed a softphone called Linphone on my Ubuntu 12.04.

Made a call to my PSTN line from my cell phone. It worked like a charm. I was able to hear the voice and talk back.

The problem:
I called from the softphone to my cell phone. I expected my asterisk box to route the call to my cell phone through the PSTN line.

I get the following error:

chan_sip.c: Call from ‘1000’ ( to extension ‘Unknown’ rejected because extension not found in context ‘from-internal’.


  1. Why is Asterisk looking for an extension to connect the call? I need to make an outgoing call using my PSTN (fxo port) line.

  2. Is trunk required for incoming as well as outgoing calls? Or is it just for outgoing calls?

  3. What is a DAHDI channel and do I need to configure a DAHDI channel for my requirement?

  4. What configurations I should change to make my outgoing calls work?

  5. Is there a sample configuration for a working setup? I would love to have someone share his/her configuration screenshots from FreePBX? Most tutorials & documentations have screenshots with default values which does not tell us which fields we MUST set and which ones could be left out as blank or default value.

I have started reading the documentations which would eventually help me get my configurations right. But having my outgoing calls work would boost my confidence.

I would try the same with FreePBX distro tomorrow.

All this and you don’t have an outbound trunk or maybe a route.

Suggest you read one of the getting started guides in the forum.

One other issue. FreePBX does not include nor distribute Asterisk, hence we generally can’t help much beyond bread and butter issues inside of FreePBX.

The FreePBX team does produce a distro (a distro is a bootable DVD that installs Asterisk/FreePBX and all the other programs needed to form a complete PBX). Some of the same folks from the FreePBX project also help out on the distro. With our distro we can help with issue beyond FreePBX itself.

He says he has a trunk created and an outbound route that uses it.

I’d suggest posting the console output that happens while attempting a call. Probably there’s something simple in the setup that got missed.

I don’t have any experience with DAHDI and FXO cards so I can’t say anything more helpful than that.

I don’t think he has a route as the from-internal context can’t match the pattern.

Or perhaps your outbound route has incorrect match patterns?

Thanks for the help offered. I installed FreePBX distro and reconfigured everything.
Then I had to configure my NAT settings to make the audio work both ways.
Then I tried calling my cell phone from the Linphone. Unfortunately, it did not work again.
I spend few days going over the settings without getting any results.
Then I had another SIP client EKIGA installed on another machine (Ubuntu 10.04). Calling my cell phone resulted in another message this time. I got the error message: The call could not be completed as dialied.
Then I tried calling another number (not mine) and it just worked. I tried calling several other numbers, it worked as well.
On my computer (Ubuntu 12.04), Linphone or Ekiga did not work for some reason. So I installed Twincle softphone and it worked like a charm. Linphone only worked for the incoming calls on Ubuntu 12.04.

Now everythign seems to work except I am unable to make calls to one phone number which is my own cell phone. Calls to the same provider (Reliance) works for other numbers.

For the completeness of this thread, I wanted to update why some of the phone calls (outgoing) were not working.

I had the Outgoing Route dial pattern set as NXXNXXXXXX. The mobile number I was trying to dial was 96914XXXXX. The 1 on the fourth digit was making Asterisk to not select this route because N matches numbers 2-9. To solve this problem I changed NXXNXXXXXX to NXXXXXXXXX

Softphones on Ubuntu 12.04:
I tried Linphone, Ekiga & SFLPhone. All of them had some issue or the other which made the softphone unusable.

Twinkle has worked just fine so far. Be aware that when Twinkle window is not active (in-focus), the simple control-tab method to get back to Twinkle window does not work. This may make you think Twinkle process is hanging.
In this scenario, the only way to activate the Twinkle GUI is by clicking on a little star icon that shows on the workspace as long as Twinkle is up.
I really appreciate the FreePBX community to help me get my Asterisk working.