Some international numbers won't work


(France) #1

Hello,

I am under Freepbx 15 and latest stable asterisk core.

My dial pattern is simple as it could be: X. allowing for any number to be dialed.

But this is not the case. I can phone Switzerland, France, England and some others but not the USA, Germany or Luxembourg.

I checked in the blocked numbers, and there is nothing. I even checked in the Asterisk database and found that the dial pattern is indeed corrected inserted.

Looking at the call event log in, the output would be for a non-working number:

Fri, Nov 13, 2020 8:42 AM CHAN_START 1605253331.29904 1605253331.29904 777 003520499241 from-internal SIP/777-000071f6
Fri, Nov 13, 2020 8:42 AM CHAN_START 1605253331.29905 1605253331.29904 s from-trunk SIP/out-000071f7
Fri, Nov 13, 2020 8:42 AM HANGUP 1605253331.29905 1605253331.29904 003520499241 003520499241 from-trunk SIP/out-000071f7
Fri, Nov 13, 2020 8:42 AM CHAN_END 1605253331.29905 1605253331.29904 003520499241 003520499241 from-trunk SIP/out-000071f7
Fri, Nov 13, 2020 8:42 AM HANGUP 1605253331.29904 1605253331.29904 777 hangup app-blackhole SIP/777-000071f6
Fri, Nov 13, 2020 8:42 AM CHAN_END 1605253331.29904 1605253331.29904 777 hangup app-blackhole SIP/777-000071f6
Fri, Nov 13, 2020 8:42 AM LINKEDID_END 1605253331.29904 1605253331.29904 777 hangup app-blackhole SIP/777-000071f6

As you can notice, I have got this app-blackhole stuff at the end.

Why does it happen this way.

Thanks in advance.


(Itzik) #2

Please post a call trace, please post a pastebin link. See instructions: https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Richard Smith) #3

If you are passing everything over to the SIP trunk then it’s likely to be more an issue their end, perhaps with the way the number is being presented?

Have you checked with them?


(France) #4

Thanks, I was head down in Freepbx 15 as I transitioned 3 weeks ago.

Actually, you were right. OpenIP (my provider) had included a new security option (smart learning… ) to prevent making calls to unused phone numbers over the latest 3 months. And they did not tell anybody :frowning:

So issue solved. Thanks !!


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.