Some gentle guidance would be appreciated

I have been using the new version 2.2.0rc1 since it has been released and while I like the new look and feel, I noted that I have never been using the database function.

I am sheepishly asking for some help for when I change the amportal.conf file to indicate auth=database, I can never login to the system. The databases seem to be there but the default for asteriskuser does not work.

I went back through the install notes on freepbx, made sure that I had all prerequisites installed. But still no result.

Could someone assist?

Thanks (in advance)

now this is not the httpd.conf file access permisson right???

the etc/httpd/httpd.conf file does not have any access control setup

how about .htaccess files

All my boxes are custom build as well with issues

I had done the svn move from tb some time ago. So, I am using asterisk 1.2.13, zaptel 1.2.13 and I upgraded freepbx from 2.1.3 .


What did u apply the update to???
TB What version???

I notice yet another strange behaviour of loging in to freepbx. When I login from a firefox on a linux machine, no problem. But when I do it from an IE on a WinXP PC, it just won’t accept any userid/password.

I tried both Firefox & Maxthon with the same results. Would not take any password. With Firefox it just keeps trying and trying and trying and never times out. With Maxthon it give me a 401 error.


admin / admin

OK, well, that didn’t work. Is there some place that I can check that the admin user in the mysql database or at least add the user + password?

actually I did find by using the phpedit that I could see the contents of ampusers in the asterisk database. The username / password for admin, is indeed admin/admin but freepbx is not recognizing the username/password. I also noted that if I go into the web interface for freepbx and create a user, the entry does indeed appear in the database but when it is beign authenticated it is not working.